Häufigkeit und Sortierung

19/06/2008 - 15:28 von Michael E. | Report spam
Hallo,

ich habe folgende Aufgabe. In einer Excel-Tablle (Excel 2003, XP SP2) stehen
in einer Spalte etwa 1000 Zahlen (Personen IDs, 4 oder 5-stellig). Dabei kann
es vorkommen, daß die Zahlen genau einmal, zweimal, dreimal oder mehr als
dreimal vorkommen. Als Beispiel sind hier die ersten 10 Zahlen (A1-A10)
2233
2235
2235
2236
2237
2238
2238
14000
14000
14000

Ich müßte folgende 2 Fragen beantworten
1. Wie hàufig ist das Ereignis 1x, 2x, 3x und 4x
(In meinem Beispiel kommen 3 Zahlen 1x vor, 2 Zahlen 2x, 1 Zahl 3x und keine
Zahl mehr als 3x)
2. Aufstellung der vorkommenden Zahlen (jede mit einer zusàtzlichen Spalte,
wie oft die Zahl vorkommt, also
2233 1
2235 2
2236 1
2237 1
2238 2
14000 3

Kann man das mit Excel (Formel, vba) irgendwie lösen?

Vielen Dank für Vorschlàge
Michael Ernst
 

Lesen sie die antworten

#1 Wolfgang Habernoll
19/06/2008 - 15:54 | Warnen spam
Hallo

"Michael E." schrieb im Newsbeitrag
news:
Hallo,

ich habe folgende Aufgabe. In einer Excel-Tablle (Excel 2003, XP SP2) stehen
in einer Spalte etwa 1000 Zahlen (Personen IDs, 4 oder 5-stellig). Dabei kann
es vorkommen, daß die Zahlen genau einmal, zweimal, dreimal oder mehr als
dreimal vorkommen. Als Beispiel sind hier die ersten 10 Zahlen (A1-A10)
2233
2235
2235
2236
2237
2238
2238
14000
14000
14000

Ich müßte folgende 2 Fragen beantworten
1. Wie hàufig ist das Ereignis 1x, 2x, 3x und 4x
(In meinem Beispiel kommen 3 Zahlen 1x vor, 2 Zahlen 2x, 1 Zahl 3x und keine
Zahl mehr als 3x)
2. Aufstellung der vorkommenden Zahlen (jede mit einer zusàtzlichen Spalte,
wie oft die Zahl vorkommt, also
2233 1
2235 2
2236 1
2237 1
2238 2
14000 3

Kann man das mit Excel (Formel, vba) irgendwie lösen?



versuche folgendes für deine Beispielbereich A1:A10, passe es deinen echten
bereichen an.

- markiere A1:A10
- Daten->Filter->Spezialfilter
[x] An andere Stelle kopieren
- kopieren nach: $B$1
[x]Keine Duplikate
OK

nun noch in C1 die Formel
=ZÄHLENWENN(A1:A10;B1) und herunterziehen.

mfG
Wolfgang Habernoll

[ Win XP Home SP-2 , XL2002 ]

Ähnliche fragen