Hauptpositionen mit Unterpositionen

25/07/2009 - 22:20 von Thomas Haland | Report spam
Hallo an alle,

ich habe folgendes Problem, für das mir keine vernünftige Lösung
einfàllt:

Es handelt sich um eine Tabelle, die mehrere Hauptpositionen enthàlt.
Davon gibt es zwei Sorten, die einen ohne Unterpositionen, die anderen
mit unterschiedlich vielen Unterpositionen.

Die erste Spalte enthàlt die Menge der jeweiligen Hauptpositionen.
Enthàlt eine Position Unterpositionen, ist in der Zeile kein Wert
eingetragen, der steht in der zweiten Spalte.
Die zweite Spalte enthàlt die Menge die zu einer Hauptposition
gehörenden Unterposition. Enthàlt eine Hauptposition keine
Unterpositionen, ist kein Wert eingetragen.
In der Dritten Spalte stehen die einzelnen Preise der Haupt- oder
Unterpositionen.

Meine Lösung funktioniert zwar, fügt jemand jedoch Zeilen ein und
kopiert die Formeln nicht nach unten, wird alles durcheinandergeworfen.

Beispiel:
A B C
1: 1
2: 2 100
3: 1 10
usw.

D1/2/3 usw.: =WENN(ISTZAHL(B1);C1*B1;A1*C1)
E1/2/3 usw.: =WENN(ISTZAHL(B2);D1+E2;D1)
F1/2/3 usw.: =WENN(UND(ISTZAHL($A1);ISTZAHL($B2));$A1*E1;$A1*C1)

Spalte D und E sind meine Hilfsspalten für Zwischenergebnisse

Ziel ist (im Beispiel), in F1 die Summe der Hauptposition zu ermitteln,
also im Beispiel 210.

Ich dachte mit "Bereich.verschieben" müßte es gehen, komme aber mit der
Funktion nicht klar.

Für hilfreiche Ideen wàre ich dankbar.

Gruß Thomas
 

Lesen sie die antworten

#1 Bernd P
26/07/2009 - 08:20 | Warnen spam
Hallo Thomas,

Du kannst Deine Daten besser organisieren:
1 2 100
1 1 10
usw.

Dann kannst Du mit TEILERGEBNIS oder mit Pivot Tabellen recht einfach
aggregieren.

Viele Grüße,
Bernd

Ähnliche fragen