Hilfe für Formel

28/04/2009 - 17:47 von friedhelm beckadolf | Report spam
Hallo und guten Tag werte newsgroup-Teilnehmer,

ich arbeite mir Office 2007 und benötige Hilfe bei einer Formel.

Hier der Beschreibung der Ausgangsparameter:

Immer wenn in einer Zelle einer der Werte "533xxx" und damit
korrespondierend in der Nachbarzelle der Wert "950140" steht, soll in einer
Ergebniszelle eine Addition der zugehörigen Werte (€) der Spalte D
zusammengefasst werden:

B ________C__________D
533100 500,00
533200 400,00
533201 950140
533202
533203
533204

Die zusammen gehörenden Werte stehen leider nicht sortenrein untereinander.

Ich habe hierfür folgende Formel erstellt:
=WENN(ODER(B28:B38S3100;B28:B38S3200;B28:B38S3201;B28:B38S3202;B28:B38S3203;B28:B38S3204);UND(C28:C38•0140)*D28+D31+D33+D35)

Die hilft aber nur weiter, weil ich die zu addierenden Zellen (D28+D31)
des Beispiels überschauen konnte. Wie muss die Formel geàndert werden, dass
die Werte der Spalte D immer nur dann benutzt werden, wenn die Bedingungen
stimmen.

Hoffe auf Unterstützung und bedanke mich im Voraus.
Grüße
Friedhelm

P.S.: Vielleicht kann mir auch jemand mitteilen, wie ich eine Tabelle in
eine Meldung setzen kann, damit die Frage eventuell leichter verstàndlich
wird.
 

Lesen sie die antworten

#1 Alexander Wolff
28/04/2009 - 17:53 | Warnen spam
Die Tastatur von friedhelm beckadolf wurde wie folgt gedrückt:
B ________C__________D
533100 500,00
533200 400,00
533201 950140
533202
533203
533204



=SUMMENPRODUKT((LINKS(B28:B38;3)S3)*(C28:C38•0140)*D28:D38) müßte es
sein (ziemlich schmutzig, ungetestet)

P.S.: Vielleicht kann mir auch jemand mitteilen, wie ich eine Tabelle
in eine Meldung setzen kann, damit die Frage eventuell leichter
verstàndlich wird.



Da hatte Peter Schleif hier in dieser Gruppe mal ein schönes
selbstgebasteltes Tool ... schau mal bei GoogleGroups nach.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen