Forums Neueste Beiträge
 

Hilfe.. Projekt komplett zerschossen

03/07/2009 - 19:56 von Christoph Engelhardt | Report spam
Servus,

ich habe heute beim Versuch mein Projekt einem kleinen Refactoring zu
unterziehen selbiges total zerschossen.

Ich habe eine SLN mit 3 csproj-Files
- xxx.csproj
- Something\xxaa.csproj
- Anotherthing\xxbb.csproj

Ich wollte xxx.csproj mit allen .cs-Dateien etc. in ein
Unterverzeichnis schieben, so das im obersten Verzeichnis nur noch die
SLN liegt.

Jedenfalls hab ich irgendwann eingesehen, dass das nicht so klappt,
wie ich mir das dachte und habe das Backup von Festplatte
eingespielt.

Problem ist:
Bisher konnte ich VC# 2008 Express ohne Adminrechte starten und alles
lief.

Jetzt:
- wenn ich mir die Einstellungen des Startprojektes ansehe (VC# 2008
Express ohne Adminrechte), dann sieht alles tip top aus.
- beim Starten des Debugvorgangs fordert er mich plötzlich auf per UAC
Adminrechte zu geben (ganz neuer Dialog für mich)
- nach dem Neustart von VC# mit Adminrechten sind die Einstellungen
des Projektes nicht mehr da (kann auf die Felder "Assemblyname",
"Standardnamespace" etc. nicht mehr zugreifen (DISABLED)). Beim Klick
auf den Karteireiter "Debuggen" schmiert VC# ab.

Bin total begeistert und weiß überhaupt nicht mehr weiter. Hat einer
von euch eine Idee, wie ich wenigstens wieder in den Ausgangszustand
zurückkomme?

Gruß Christoph
 

Lesen sie die antworten

#1 Stefan Falz [MVP]
03/07/2009 - 21:25 | Warnen spam
Hallo Christoph,

"Christoph Engelhardt" schrieb:

Ich wollte xxx.csproj mit allen .cs-Dateien etc. in ein
Unterverzeichnis schieben, so das im obersten Verzeichnis nur noch die
SLN liegt.

Jedenfalls hab ich irgendwann eingesehen, dass das nicht so klappt,



Hmmm, eigentlich klappt das schon. Du musst nur die Referenzen der Projekte
anpassen und ggfs. noch weitere Pfade. Mache ich aber grundsàtzlich auch
ab und an, wenn ich mich beim Anlegen vertan hab.

- nach dem Neustart von VC# mit Adminrechten sind die Einstellungen
des Projektes nicht mehr da (kann auf die Felder "Assemblyname",
"Standardnamespace" etc. nicht mehr zugreifen (DISABLED)). Beim Klick
auf den Karteireiter "Debuggen" schmiert VC# ab.



Hmmm. Passiert das auch bei einem neuen bzw. anderen Projekt? Oder nur
bei diesem hier?

Tschau, Stefan
Microsoft MVP - Visual Developer ASP/ASP.NET
http://www.asp-solutions.de/ - Consulting, Development
http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

Ähnliche fragen