Hilfe wie komme ich wieder an mein LVM

22/10/2015 - 08:00 von Dani Dagio | Report spam
Guten Morgen,

anscheinend hab ich das mit dem LVM doch noch nicht ganz verstanden.

Ich habe ein Raid mit mdadm erstellt (/dev/md0). Dieses habe ich mit
crypt verschlüsselt (/dev/mapper/raid1) und anschließend darauf eine
Partition für LVM angelegt.

Wenn ich mit fdisk -l /dev/mapper/raid1 mit den Inhalt anzeigen lasse,
sehe ich auch das /dev/mapper/raid1p1, aber es erscheint nicht in
/dev/mapper und vgscan findet leider auch nichts mehr.

Kann mir jemand erklàren, wo mein Denkfehler liegt.

Liebe Grüße
Dani
 

Lesen sie die antworten

#1 Marc Haber
22/10/2015 - 09:10 | Warnen spam
On Thu, 22 Oct 2015 07:53:59 +0200, "Dani Dagio"
wrote:
anscheinend hab ich das mit dem LVM doch noch nicht ganz verstanden.

Ich habe ein Raid mit mdadm erstellt (/dev/md0). Dieses habe ich mit
crypt verschlüsselt (/dev/mapper/raid1) und anschließend darauf eine
Partition für LVM angelegt.

Wenn ich mit fdisk -l /dev/mapper/raid1 mit den Inhalt anzeigen lasse,
sehe ich auch das /dev/mapper/raid1p1, aber es erscheint nicht in
/dev/mapper und vgscan findet leider auch nichts mehr.

Kann mir jemand erklàren, wo mein Denkfehler liegt.



Es ist grundsàtzlich keine gute Idee, ein Raid-Device nochmal zu
partitionieren. Damit kommen etliche Tools nicht klar.

Die Aufgabe kann man auf viele verschiedene Arten angehen. Meine
Methode entspricht auch nicht ganz dem Standard und wird von Debian
aus der Tüte auch nicht direkt unterstützt. Deswegen ziehe ich mich
jetzt zurück und überlasse das Feld den Leuten, die sich mit dem
Debian-Weg besser auskennen.

Grüße
Marc
Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " | http://www.zugschlus.de/
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834

Ähnliche fragen