http 503 service unavailalble

05/12/2013 - 18:28 von Thomas Barth | Report spam
Hallo,
irgendetwas hat sich heute geàndert und ich weiß nicht was. Server in
einem Netzwerk erhalten bei Aufruf einer URL eines Zielrechners
außerhalb des Netzwerk die Fehlermeldung: 503 Service Unavailable. Wenn
ich aber die URL des Zielrechners in meinem Browser eingebe, wird die
Anfrage ganz normal abgearbeitet. Der Service funktioniert. Und die über
den Browser gemachte HTTP-Anfrage wird auch im apache access log
protokolliert, nicht aber, wenn die Anfrage von einem dieser Server aus
dem Netzwerk kommt. wget sagt dann:

Auflösen des Hostnamen domain.de <ip-adresse>
Verbindungsaufbau zu domain.de[ip-adresse]:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 503 Service Unavailable
18:06:02 FEHLER 503: Service Unavailable.

Ich musste heute auch auf allen Servern einen anderen dn server angeben,
damit hosts aufgelöst werden.
Hat jemand vielleicht eine Idee, warum es zu dieser Fehlermeldung kommt,
obwohl der Service eigentlich funktioniert?

Gruß, Thomas
 

Lesen sie die antworten

#1 Thomas PointedEars Lahn
05/12/2013 - 23:09 | Warnen spam
Thomas Barth wrote:

irgendetwas hat sich heute geàndert und ich weiß nicht was. Server in
einem Netzwerk erhalten bei Aufruf einer URL eines Zielrechners
außerhalb des Netzwerk die Fehlermeldung: 503 Service Unavailable. Wenn
ich aber die URL des Zielrechners in meinem Browser eingebe, wird die
Anfrage ganz normal abgearbeitet. Der Service funktioniert. Und die über
den Browser gemachte HTTP-Anfrage wird auch im apache access log
protokolliert, nicht aber, wenn die Anfrage von einem dieser Server aus
dem Netzwerk kommt. wget sagt dann:

Auflösen des Hostnamen domain.de <ip-adresse>
Verbindungsaufbau zu domain.de[ip-adresse]:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 503 Service Unavailable
18:06:02 FEHLER 503: Service Unavailable.

Ich musste heute auch auf allen Servern einen anderen dn server angeben,



"dn"?

damit hosts aufgelöst werden.
Hat jemand vielleicht eine Idee, warum es zu dieser Fehlermeldung kommt,
obwohl der Service eigentlich funktioniert?



Wenn es keinen Eintrag im Access-Log von Apache gibt, und PHP als Apache-
Modul, CGI oder FastCGI làuft, ist es IMHO kein PHP-Problem und damit hier
fhcsal. Steht denn etwas im *Error*-Log?

Es könnte sein, dass die „Server in einem Netzwerk“ einen fhcsal
konfigurierten Proxy verwenden, und somit der Request somit gar nicht beim
Server, der den Service (ich nehme mal an, ein mit PHP realisierter SOAP-
oder REST-Webservice, sonst bist du hier sowieso fhcsal) anbietet.

PointedEars

Twitter: @PointedEars2
Please do not Cc: me. / Bitte keine Kopien per E-Mail.

Ähnliche fragen