Hyperlink anzeigen abhängig von Zellwert

13/11/2009 - 14:45 von Michael Jakobs | Report spam
Hallo Leute,

ich habe ein Tool mit dem ich in Excel Vorlagen erstelle, woraus dann
Scriptgesteuert Ergebnissheets erstellt werden. Nun möchte ich sowas wie
eine Übersichtseite mit Links erstellen und bin dabei über die Funktion
Hyperlink gestolpert. Nach einigen Fehlversuchen funktioniert das
mittlerweile ziemlich gut. An einer Stelle komme ich aber gerade nicht
weiter.

Folgendes Beispiel: Ich habe eine Excel-Mappe die als Mappe1.xls
gespeichert ist. Es gibt genau ein Blatt mit 3 relevanten Spalten.

Spalte A hat folgende Eintràge
1
2
0
3

In Zelle B1 steht folgende Formel:
=WENN(A1<>0;HYPERLINK("[Mappe1.xls]A!C"&ZEILE(A1);A1);"Kein Link")

Die Zelle B1 kopiere ich nun runter in B2 bis B4. Das Ziel soll sein
dass immer dann ein Link auf die Spalte C (bzw. auf die Zelle der
aktuellen Zeile in Spalte C) angezeigt wird, wenn in A ein Wert ungleich
0 ist. Das funktioniert auch wunderbar für alle Zeilen die in A
tatsàchlich einen Wert ungleich 0 haben. In Zelle B3 wird auch "Kein
Link" angezeigt. Allerdings wird das ganze als Link angezeigt (also
unterstrichen), der auch anklickbar ist. Danach kommt dann eine
Fehlermeldung, dass die Datei nicht gefunden wurde. Ist ja auch kein
Wunder, der Link ist ja auch ungültig.

Irgendjemand eine Idee wie ich das umgehene kann? Im Falle das die Zelle
in A 0 ist, soll tatsàchlich in B kein anklickbarer Link erscheinen.


Grüße
Michael
 

Lesen sie die antworten

#1 Michael Jakobs
13/11/2009 - 14:55 | Warnen spam
Michael Jakobs schrieb:

ich habe ein Tool mit dem ich in Excel Vorlagen erstelle, woraus dann
Scriptgesteuert Ergebnissheets erstellt werden. Nun möchte ich sowas wie




Ups, vergessen: XL2003 falls das noch wichtig ist.


Michael

Ähnliche fragen