I/O-Fehler trotz RAID 1?

17/07/2011 - 17:01 von Hauke Laging | Report spam
Moin,

ich bin verwirrt. Ich habe ein RAID-1 aus zwei Platten. Nun bekomme ich beim
Zugriff auf das RAID I/O-Fehler. Wie kann das sein? Wieso holt das RAID die
Daten nicht von der anderen Platte? Muss man das extra konfigurieren, steht
diese naheliegende Möglichkeit bewusst nicht zur Verfügung? Laut
/proc/mdstat sind in dem RAID beide Platten aktiv.

dmesg liefert nur Fehler für sda und auch nur für zwei Sektoren (die in zwei
gerade erst erzeugten Archivdateien liegen). Insbesondere irritiert mich
folgendes:

[sda] Add. Sense: Unrecovered read error - auto reallocate failed

Welche Gründe gibt es dafür, dass auto reallocate versagt? Ich weiß nur den,
dass keine Ersatzsektoren mehr da sind. SMART widerspricht dem aber:

Reallocated_Sector_Ct 0x0033 100 100 036

Nach meinem Verstàndnis sind erst dann keine mehr da, wenn der vorletzte
Wert von 100 auf 36 gefallen ist.

Was ist nun zu tun? Die beiden Sektoren manuell von sdb auf sda kopieren?
dmesg sagt: "end_request: I/O error, dev sda, sector 241522148". Das müsste
also mit
dd if=/dev/sdb of=/dev/sda skip$1522148 bsQ2 count=1
gehen. Oder?


F'up2 dcoulm


CU

Hauke
http://www.hauke-laging.de/ideen/
D44C 6A5B 71B0 427C CED3 025C BD7D 6D27 ECCB 5814
 

Lesen sie die antworten

#1 Helmut
17/07/2011 - 17:11 | Warnen spam
Hallo, Hauke,

Du meintest am 17.07.11:

ich bin verwirrt. Ich habe ein RAID-1 aus zwei Platten. Nun bekomme
ich beim Zugriff auf das RAID I/O-Fehler.



[...]

Was ist nun zu tun?



2 neue Platten einrichten, darauf das Backup zurückspielen.

Du hast doch ein Backup?

Viele Gruesse
Helmut

"Ubuntu" - an African word, meaning "Slackware is too hard for me".

Ähnliche fragen