iCal Server auf OD-Replik

06/04/2009 - 07:03 von jhjadmin | Report spam
HEUL und Moin Moin!

ich versuche gerade den iCal-Server zum laufen zu bringen. Auf meinem
OD-Master klappt das auch wunderbar. Aber versuche ich es auf einem
anderen Server, gibt es folgende Fehlermeldung:

+ + +
twistedcaldav.directory.appleopendirectory.OpenDirectoryInitError:
Open Directory (node=/Search) has no /Computers records with a virtual
hostname: xxxx.example.com
+ + +

Jetzt habe ich gelesen, dass der iCal-Server nur auf einem OD-Master
làuft???!!! Das kann ja wohl nicht sein?!

Hat jemand einen iCal-Server auf einem anderen Server laufen und kann
mir erklàren was ich falsch mache. DNS habe doppelt und dreifach
geprüft. Habe sogar zwischenzeitlich Web-Service angemacht und vhost
angelegt.

Wàre sehr dankbar.

Gruss aus Hamburg-Altona

PS Wir reden natürlich von 10.5.6
 

Lesen sie die antworten

#1 Hannes Gnad
06/04/2009 - 22:56 | Warnen spam
jhjadmin wrote:

Hallo.

HEUL und Moin Moin!

ich versuche gerade den iCal-Server zum laufen zu bringen. Auf meinem
OD-Master klappt das auch wunderbar. Aber versuche ich es auf einem
anderen Server, gibt es folgende Fehlermeldung:

+ + +
twistedcaldav.directory.appleopendirectory.OpenDirectoryInitError:
Open Directory (node=/Search) has no /Computers records with a virtual
hostname: xxxx.example.com
+ + +

Jetzt habe ich gelesen, dass der iCal-Server nur auf einem OD-Master
làuft???!!! Das kann ja wohl nicht sein?!



Lustiger Zufall, genau diese Meldung hatte ich heute auch. Ich kann
den Hintergrund noch nicht korrekt und in aller Tiefe beschreiben,
dazu fehlt mir gerade die Zeit zur Recherche.

Es hat ernstlich mit der MAC-Adresse der Maschine zu tun. Diese
wird bei der "Erhebung" der Maschine vom "Standalone"-Server zum
OD-Master in die OD-Datenbank geschrieben, mit dem Eintrag für
den Computer. Der iCal Server erwartet nun für seinen erfolgreichen
Erststart genau diese Zuordnung wie bei der OD-Erschaffung vorzu-
finden - ist die MAC mittlerweile eine andere, wirft er diese
Fehlermeldung. An einem Xserve kann man das dadurch haben, wenn
man *nach* der OD-Erhebung das Netzwerkkabel auf den anderen Port
klemmt, oder eine "Link Aggregation" hochzieht. Bei Dir auch so?


Hat jemand einen iCal-Server auf einem anderen Server laufen und kann
mir erklàren was ich falsch mache. DNS habe doppelt und dreifach
geprüft. Habe sogar zwischenzeitlich Web-Service angemacht und vhost
angelegt.

Wàre sehr dankbar.



Bitte sehr.


Beste Gruesse, Hannes Gnad
Apple Distinguished Professional http://www.apfelwerk.de/
* Mac OS X 10.5 Leopard - seit 26. Oktober 2007 - http://www.apple.de/ *

Ähnliche fragen