IceWM: Fenster ohne inhalt, unkaputtbar

12/09/2009 - 08:59 von Ralph Stahl | Report spam
Moin,

seit einiger zeit habe ich ein merkwürdiges Phànomen. Ich starte zB.
skype und sim über das startup-Script von IceWM, was bis vor kurzem auch
gut funktioniert hat - beides landete wegen eines passenden Eintrags in
winoptions (auch IceWM) in der Taskleiste.

Jetzt ist es meistens so, daß beides dort nicht mehr sichtbar ist
(obwohl es làuft, siehe ps), dafür gibts aber ein Fensterchen ohne
Beschriftung und leer und winzig (nur "_X"). Selbiges ist nicht weg zu
bekommen, auch bekomme ich die GUI von skype oder sim nie zu Gesicht.
Auch wenn ich beide kille, bleibt das Fenster. Starte ich dann skype
neu, bleibt beides unsichtbar.

Erst wenn ich mich auslogge (alt-ctrl-bs) und X wieder hochfahre, geht
(immer!) alles normal.

Was ist das? Kann ich dem irgendwie beikommen? Ein xprop auf das leere
Fenster liefert lediglich

WM_PROTOCOLS(ATOM): protocols WM_DELETE_WINDOW

Ich habe Fedora 8 und natürlich einiges nachinstalliert, aber (fast...)
immer über yum. Mir ist kein Zeitpunk + Handlung bewußt, wonach es nicht
mehr ging.

Irgend ne Idee?
Ralph
 

Lesen sie die antworten

#1 Jörg Sommer
12/09/2009 - 11:40 | Warnen spam
Hallo Ralph,

Ralph Stahl schrieb:
seit einiger zeit habe ich ein merkwürdiges Phànomen. Ich starte zB.
skype und sim über das startup-Script von IceWM, was bis vor kurzem auch
gut funktioniert hat - beides landete wegen eines passenden Eintrags in
winoptions (auch IceWM) in der Taskleiste.

Jetzt ist es meistens so, daß beides dort nicht mehr sichtbar ist
(obwohl es làuft, siehe ps), dafür gibts aber ein Fensterchen ohne
Beschriftung und leer und winzig (nur "_X"). Selbiges ist nicht weg zu
bekommen, auch bekomme ich die GUI von skype oder sim nie zu Gesicht.
Auch wenn ich beide kille, bleibt das Fenster. Starte ich dann skype
neu, bleibt beides unsichtbar.



So àhnlich habe ich das auch schon gesehen. Ich habe das immer als Bug im
IceWM abgetan und da ich dieses Fenster wieder weg bekommen haben, wenn
ich die Anwendung beendet habe (notfalls mit kill), reichte mir das.

Welche Version vom IceWM hast Du denn? So vom Gefühl her, würde ich
sagen, ich habe den Fehler nicht mehr seit dem Update auf 1.3 gesehen.

Schöne Grüße, Jörg.
Du hast keine Chance – also nutze sie.

Ähnliche fragen