ICS funktioniert nur halb

11/07/2008 - 16:34 von Dominik Schmidt | Report spam
Hallo,

folgender Fall: Ein Netzwerk mit mehreren Computern (alle Windows XP)
und ein Laptop (XP Pro, alle Updates), der die restlichen Computer mit
dem Internet verbinden soll. Es gibt auch einen DHCP-Server, allerdings
nicht auf dem Laptop (dieser weist normalerweise allen Computern eine IP
zu).
Er hat also zwei NIC: Einmal das Modem und einmal die Schnittstelle zu
den anderen Computern. Die Verbindungen sind soweit alle
funktionstüchtig, also alle Computer können untereinander kommunizieren
und der Laptop kommt ins Internet.
Nun habe ich bei der Modemverbindung alle drei ICS-Haken aktiviert
(Anderen Benutzern gestatten...zu verwenden, Verbindung herstellen
wenn..., Anderen Benutzern gestatten...zu steuern).
Daraufhin konnten die anderen Computer, an denen ich nichts geàndert
hatte (Gateway war also noch der DHCP-Computer, weil automatisch
zugewiesen), plötzlich für etwa eine Minute ins Internet. Danach nicht mehr.
Ich habe also die Windows-Firewall auf dem Laptop deaktiviert, mit der
Folge, dass die Verbindung wieder da war. Das blieb auch einige Zeit
nach dem Aktivieren der Firewall so, bis irgendwann plötzlich wieder die
Verbindung weg war (ich spreche nach wie vor von der Internetverbindung
der anderen Computer), ohne dass ich ein System dahinter erkennen konnte.

Wenn ich die Firewall jetzt deaktiviert lasse, geht es trotzdem nicht
mehr ohne weiteres - ich muss auf dem Client den Laptop als Gateway
einstellen. Dann funktioniert die Verbindung.

Das zweite Problem ist die Steuerung. Ich habe ja den dritten Haken
(Anderen Computern gestatten...zu steuern) auch aktiviert. Damit müsste
ich eigentlich in den Netzwerkverbindungen eines Clients die
Modemverbindung des Laptops steuern können. Das kann ich aber nicht - es
wird überhaupt nichts von dieser Modemverbindung angezeigt.

Daher meine Fragen:
- Warum konnten die anderen Computer ohne Änderung der
Netzwerkeinstellungen (Gateway) kurzzeitig ins Internet und danach nur
noch mit manueller Gateway-Einstellung?
- Wie muss ich die Firewall auf dem Laptop konfigurieren, damit die ICS
funktioniert (Port 80 habe ich bereits vergeblich freigegeben)
- Warum funktioniert die Steuerung der Modemverbindung nicht?

Ich entschuldige mich für den langen Text, ich hoffe, es ist halbwegs
verstàndlich...
Danke für jeden Tipp!
 

Lesen sie die antworten

#1 Ralf Breuer
11/07/2008 - 16:58 | Warnen spam
Dominik Schmidt schrieb:

Hallo Dominik,

folgender Fall: Ein Netzwerk mit mehreren Computern (alle Windows XP)
und ein Laptop (XP Pro, alle Updates), der die restlichen Computer mit
dem Internet verbinden soll. Es gibt auch einen DHCP-Server,
allerdings nicht auf dem Laptop (dieser weist normalerweise allen
Computern eine IP zu).
Er hat also zwei NIC: Einmal das Modem und einmal die Schnittstelle zu
den anderen Computern. Die Verbindungen sind soweit alle
funktionstüchtig, also alle Computer können untereinander
kommunizieren und der Laptop kommt ins Internet.



Ist auf der Verbindung zum Modem noch TCP/IP aktiviert? Wenn ja, ist da ein
anderes Subnetz als im LAN?
Hat die LAN-Verbindung auf dem Laptop die Standard-IP 192.168.0.1? Wenn ja,
ist hier ein DHCP-Server aktiv.

Nun habe ich bei der Modemverbindung alle drei ICS-Haken aktiviert
(Anderen Benutzern gestatten...zu verwenden, Verbindung herstellen
wenn..., Anderen Benutzern gestatten...zu steuern).
Daraufhin konnten die anderen Computer, an denen ich nichts geàndert
hatte (Gateway war also noch der DHCP-Computer, weil automatisch
zugewiesen), plötzlich für etwa eine Minute ins Internet. Danach
nicht mehr.



Kannte der DHCP-Server das richtige Gateway?

Ich habe also die Windows-Firewall auf dem Laptop deaktiviert,



Deaktivierte Firewall bei bestehender Modem-Verbindung? Mutig ;-)

mit der Folge, dass die Verbindung wieder da war. Das
blieb auch einige Zeit nach dem Aktivieren der Firewall so,
bis irgendwann plötzlich wieder die Verbindung weg war
(ich spreche nach wie vor von der Internetverbindung der anderen
Computer), ohne dass ich ein System dahinter erkennen
konnte.
Wenn ich die Firewall jetzt deaktiviert lasse, geht es trotzdem nicht
mehr ohne weiteres - ich muss auf dem Client den Laptop als Gateway
einstellen. Dann funktioniert die Verbindung.



Gateway muss der Laptop sein. Kannst Du Deinem DHCP-Server das nicht
beibringen?

Das zweite Problem ist die Steuerung. Ich habe ja den dritten Haken
(Anderen Computern gestatten...zu steuern) auch aktiviert. Damit
müsste ich eigentlich in den Netzwerkverbindungen eines Clients die
Modemverbindung des Laptops steuern können. Das kann ich aber nicht -
es wird überhaupt nichts von dieser Modemverbindung angezeigt.



Auf allen Rechnern müssen die Dienste "Universeller Plug & Play Geràtehost"
und "SSDP-Suchdienst" aktiv sein für die Steuerung.

- Wie muss ich die Firewall auf dem Laptop konfigurieren, damit die
ICS funktioniert



Das sollte XP automatisch korrekt erledigen.

Gruß
Ralf
Ich mag kein TOFU. Siehe http://einklich.net/usenet/zitier.htm
Bei Direkt-Mails NOSPAM entfernen

Ähnliche fragen