IE 7.0 (Windows XP) stürzt bei bestimmten Seiten/Aktionen einfach ab?

11/11/2008 - 17:42 von Paul Ebermann | Report spam
Hallo,

ich habe (als Programmierer/Maintainer einer PHP/HTML-Webapplikation)
in den letzten zwei Tagen von zwei verschiedenen Nutzern Beschwerden
bekommen, dass der Internet Explorer an bestimmten Stellen
reproduzierbar abstürzt - d.h. das Browserfenster verschwindet
einfach, ohne irgend eine Fehlermeldung.
Ich bin mir sicher, dass kein window.close() verwendet wird, bevor
danach gefragt wird.

Die Browserkennungen in unserem Protokoll sind:
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; InfoPath.1)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR
1.1.4322; .NET CLR 2.0.50727)

Das heißt, es ist IE 7.0 auf Windows XP, wenn ich das richtig sehe.

Ich kann das frühestens morgen selbst mit einem IE 7 ausprobieren,
aber zur Zeit sieht es (anhand der Beschreibungen und der
Gemeinsamkeiten der beiden Fàlle) so aus, dass es sich um einen Button
(bzw. zwei verschiedene in zwei Formularen auf verschiedenen Seiten)
handelt, dessen Beschriftung vom "value" abweicht:

<button type='submit' name='sendu' value='notu'>Nova noto!</button>

<button type='submit' name='sendu' value='Sxangxu'>&#348;an&#285;u</
button>

Ein Klick darauf führt offenbar zum Schließen des Browserfensters.
Bei àlteren IE (6.0) hatte ich an solchen Stellen bereits das Problem,
dass der Text anstatt des Wertes mit dem Formular geschickt wurde.

Ist dazu bereits etwas bekannt? Und wie kann ich als Webmaster das
vermeiden?

Danke
Paul
 

Lesen sie die antworten

#1 Paul Ebermann
12/11/2008 - 11:29 | Warnen spam
"Paul Ebermann" skribis:

ich habe (als Programmierer/Maintainer einer PHP/HTML-Webapplikation)
in den letzten zwei Tagen von zwei verschiedenen Nutzern Beschwerden
bekommen, dass der Internet Explorer an bestimmten Stellen
reproduzierbar abstürzt - d.h. das Browserfenster verschwindet
einfach, ohne irgend eine Fehlermeldung.
[...]
Das heißt, es ist IE 7.0 auf Windows XP, wenn ich das richtig sehe.



Noch zwei Systeme, auf denen das auftritt:

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)

Beides IE 7.0, einmal auf Vista, einmal auf XP.
Und da das jetzt meine Systeme sind, konnte ich den
Fehler etwas genauer lokalisieren ...

-
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<style type="text/css">
button[value="egal"] {}
</style>
<title>IE-Bug</title>
</head>
<body>
<p><button>notu</button></p>
</body>
</html>
-
Diese Datei loest das Problem aus - schon das Laden
der Datei, nicht erst der Klick auf den Button.
Wer es ausprobieren will (vorher aufpassen, dass keine
wichtigen Webseiten, bei denen man die Session nicht
verlieren will, im IE geoeffnet sind):

http://www.math.hu-berlin.de/~ebermann/test/nova-noto.html
http://www.math.hu-berlin.de/~ebermann/test/nova-noto-x.html

(Die zweite ist die XHTML-Version davon.)

Ist dazu bereits etwas bekannt? Und wie kann ich als Webmaster das
vermeiden?



Es sieht so aus, als wuerde es ausreichen, die
entsprechende CSS-Regel fuer button mit Attributwert
rauszuwerfen - werde ich gleich mal ausprobieren.

Wo kann man bei Microsoft Bugs melden?


Paul

Ähnliche fragen