IE-7-Hänger

22/07/2009 - 12:43 von Andreas Born | Report spam
Hallo,

ich habe seit einiger Zeit ein seltsames Problem, aus dem ich nicht
schlau werde. Und zwar passiert es regelmàßig, daß sich der IE beim
Laden einer Seite für bis zu 30 Sekunden lang aufhàngt und in dieser
Zeit nicht ansprechbar ist.

Eine Analyse des Netzwerk-Traffics zeigt, daß in diesen Fàllen eine
tcp-verbindung erfolgreich aufgebaut werden konnte, und auch der
HTTP-Request abgesetzt worden ist. Doch aus unerfindlichen Gründen
bleibt die TCP- (und damit auch HTTP-) Antwort aus, sodaß der TCP-Stack
in diversen Zeitabstànden eine TCP-Retransmission sendet. Nach einiger
Zeit làuft die Verbindung dann auch meist weiter und der IE reagiert
wieder.

Daß die TCP-Verbindung gestört ist liegt offenbar nicht am IE, dieser
kann ja nichts dafür, wenn die Antwort einfach eine zeitlang ausbleibt.
Allerdings wundert mich, daß er in dieser Zeit nicht reagiert. So könnte
man wenigstens den Link erneut anklicken und damit eine Neue Verbindung
öffnen. Auch bei Tippfehlern in der URL "hàngt" der IE, wenn er die
domain z.B. nicht auflösen kann.

Gibt es eine Möglichkeit den IE dazu zu bringen, daß er nicht blockiert,
wenn er eine Seite nicht laden oder eine Adresse nicht auflösen kann?

Und kennt jemand evtl. das geschilderte problem mit der "schlafenden"
TCP-Verbindung?

Ach so, es geht um den IE 7, Version 7.0.5730.11; das problem tritt auch
auf, wenn ich den IE7 ohne Addons starte.


Viele Grüße,
Andreas
 

Lesen sie die antworten

#1 Ottmar Freudenberger
22/07/2009 - 17:59 | Warnen spam
"Andreas Born" schrieb:

Ach so, es geht um den IE 7, Version 7.0.5730.11; das problem tritt auch
auf, wenn ich den IE7 ohne Addons starte.



Und die Windows-Version ist? Windows XP oder Windows Server 2003 mit
welchem jeweiligen Service Pack?

Lösch zunàchst einmal die Temporàren Internetdateien über die Inter-
netoptionen und schau nach, ob für sie eine vernünftige Größe zw.
50 und maximal 100 MB voreingestellt ist.

Wuselt ein Virenscanner im Hintergrund? Falls ja, welcher?

Was den fehlenden Traffic angeht, nachdem obige Maßnahmen ergriffen
wurden:

Eine Personal Firewall Saftware (exklusiv oder in einer "Suite" ent-
halten) wirst Du wohl nicht einsetzen, oder? Falls doch, schau dort an
erster Stelle nach.

Setzt Du keinen solchen Schmodder ein, leg einen Systemwiederherstellungs-
punkt an und versuchs anschließend mit einem "netsh winsock reset", das
Du unter "Ausführen" im Startmenü eingibst. Danach Windows neu starten
und schauen, ob das Problem noch existiert.

Bye,
Freudi
Macht euer Windows sicherer: http://windowsupdate.microsoft.com - jetzt!
http://www.microsoft.com/germany/sicherheit/
Infos zu aktuellen Patches für IE, OE und WinXP: http://patch-info.de

Ähnliche fragen