IIS 6 Neustart beim Anlegen eines Virtuellen Verzeichnisses

22/01/2008 - 10:56 von Andreas Pfanner | Report spam
Hallo,

bei unserem produktiven Applikationsserver kommt es sehr hàufig vor, dass
der komplette Server (sàmtliche Websites) für einige Sekunden nicht
erreichbar ist, wenn ein neues Virtuelles Verzeichnis für eine ASP.NET 1.1
oder 2.0 Anwendung eingerichtet wird. Ersichtlich ist hierbei, dass alle
Application Pools automatisch gestoppt werden. Durch manuelles durchstarten
der Pools kann die Ausfallzeit verkürzt werden.

Die Vorgehensweise ist folgende:
Wir legen ein neues Virtuelles Verzeichnis unterhalb einer Website an,
definierend anschließend die richtige ASP.NET Version und den dazu passenden
Application Pool (1.1 und 2.0 Applikationen getrennt). Bei einem Klick auf
OK dauert es dann meist einige Sekunden, bis das Fenster weggeht, in der
Zeit passiert dann der geschildete Ausfall und die gestoppten App Pools sind
ersichtlich. Gelegentlich funktioniert es aber auf Anhieb und ohne
Wartezeit, dann làuft der Server auch ohne Ausfall weiter. Sollte das nicht
die Regel sein?

Hat jemand eine Idee, woran das liegen könnte?

Danke!

LG
Andreas
 

Lesen sie die antworten

#1 Samaschke, Karsten
22/01/2008 - 11:33 | Warnen spam
Andreas Pfanner schrieb:

Hat jemand eine Idee, woran das liegen könnte?



Nur mal aus der Hüfte geschossen: Kann es sein, dass ihr

- Applikationen habt, die lange benötigen, um sich beenden (viele
Ressourcen nutzen, etc)?
- Einen Virenscanner am Laufen habt?
- Ein in sich regelmàßig ausgelastetes System habt?

Das wàren so Punkte, bei denen ich mir vorstellen kann, dass es zu
Problemen kommen *könnte*.

Mit freundlichen Gruessen / Best regards,

Karsten Samaschke
IT-Consulting, IT-Development, IT-Training
Homepage: http://www.ksamaschke.de
Blog: http://www.karsan.de
Foren: http://www.aspxperts.de

Sent via MacBook / Windows Vista

Ähnliche fragen