IIS FTP-Server oder Apache Webserver: Netzwerkpfad als virtuelles Verzeichnis

15/05/2010 - 09:21 von Dominik Schmidt | Report spam
Hallo,

auf einer Maschine làuft sowohl ein IIS FTP-Server, als auch ein Apache
Webserver.
Bei beiden möchte ich ein virtuelles Verzeichnis hinzufügen, das auf einen
Netzwerkpfad zeigt. Bei beiden funktioniert das nicht.

Nennen wir den Netzwerkpfad \\PC\Freigabe\Ordner1
Den habe ich bereits als Laufwerk M: gemountet. Über den Explorer kann ich
also zum Beispiel problemlos darauf zugreifen.

IIS:
FTP-Site auswàhlen - Aktion - Neu - Virtuelles Verzeichnis - Alias angeben
Im nàchsten Schritt will ich über den Durchsuchen-Button das Laufwerk M:
auswàhlen. Wenn ich das mache, ist der OK-Button deaktiviert.
Also gebe ich M:\ manuell ein.
Der Status vom neuen Verzeichnis ist dann "Das System kann den angegebenen
Pfad nicht finden.".
Also in den Verzeichniseigenschaften umstellen auf "In einem Verzeichnis
auf einem anderen Computer" und UNC-Pfad angeben. Status: "Zugriff
verweigert". Client-Fehlermeldung: "Anmeldung fehlgeschlagen: Unbekannter
Benutzername oder falsches Passwort.".
Obwohl die Logindaten eigentlich zwischengespeichert sein müssten, da ich
diese beim Zugriff (auf diesen Netzwerkpfad) über den Explorer eingegeben
habe.
Also bei "Verbinden als" den Haken rausnehmen und die Logindaten für den
Computer "PC" eingeben.
Kein Unterschied.

Apache:
An die httpd.conf habe ich folgende Zeile angehàngt:
Alias /Ordner1 M:/
Der Aufruf /Ordner1 führt mich aber zu meiner 404-Fehlerseite.
Das Modul ist geladen ("LoadModule alias_module modules/mod_alias.so" ist
nicht auskommentiert).


Bin für jeden Tipp dankbar.
 

Lesen sie die antworten

#1 Thomas D.
20/05/2010 - 16:38 | Warnen spam
Hallo,

Dominik Schmidt schrieb:
IIS:
FTP-Site auswàhlen - Aktion - Neu - Virtuelles Verzeichnis - Alias angeben
Im nàchsten Schritt will ich über den Durchsuchen-Button das Laufwerk M:
auswàhlen. Wenn ich das mache, ist der OK-Button deaktiviert.
Also gebe ich M:\ manuell ein.
Der Status vom neuen Verzeichnis ist dann "Das System kann den angegebenen
Pfad nicht finden.".
Also in den Verzeichniseigenschaften umstellen auf "In einem Verzeichnis
auf einem anderen Computer" und UNC-Pfad angeben. Status: "Zugriff
verweigert". Client-Fehlermeldung: "Anmeldung fehlgeschlagen: Unbekannter
Benutzername oder falsches Passwort.".
Obwohl die Logindaten eigentlich zwischengespeichert sein müssten, da ich
diese beim Zugriff (auf diesen Netzwerkpfad) über den Explorer eingegeben
habe.
Also bei "Verbinden als" den Haken rausnehmen und die Logindaten für den
Computer "PC" eingeben.
Kein Unterschied.



Der IIS arbeitet unter den IUSER_* Benutzern. D.h. diese Nutzer müssen auf
diese Ressource zugreifen können.

Mit welcher IIS-Version arbeitest Du?
Siehe
<http://www.microsoft.com/technet/pr...r=true>

Du solltest Dir aber überlegen, ob Du das wirklich willst. Es entsteht
dabei eine neue Fehlerquelle.


Apache:
An die httpd.conf habe ich folgende Zeile angehàngt:
Alias /Ordner1 M:/
Der Aufruf /Ordner1 führt mich aber zu meiner 404-Fehlerseite.
Das Modul ist geladen ("LoadModule alias_module modules/mod_alias.so" ist
nicht auskommentiert).



Wenn ein 404-Fehler kommt, stimmt etwas mit der Konfiguration nicht.
Gilt der Alias auch für dieses Web (VHost)?


Grüße
Thomas

Ähnliche fragen