IIS7 sucht laufend web.config

12/07/2009 - 16:23 von Stefan Huber | Report spam
hallo zusammen,

ich habe einen iis7 unter w2008 vor kurzen neu in betrieb genommen.
darauf sind einige dotnet webseiten abgelegt. diese funktionieren prima.

nun zu dem problem: eine webseite soll lediglich png-bilder von einem
netzwerklaufwerk
über http ausliefern. ich habe hierfür eine seite im iis angelegt und als
pfad direkt das
netzlaufwerk angegeben:

<application path="/" applicationPool="test.de">
<virtualDirectory path="/"
physicalPath="\\192.168.2.19\vetiles" logonMethod="ClearText" />
</application>

mein problem ist nun das laufend der defaultapp pool abstürzt deswegen.
auffallen tut mir auch, dass der iis7 laufend versucht von dem verknüpften
netzlaufwerk die
web.config zu lesen. diese existiert auf dem netzlaufwerk auch nicht.
am liebsten hàtte ich auf dieser seite das dotnet komplett deaktiviert. die
seite muss
ja lediglich die png-bilder über http ausliefern.

weis jemand wie man für eine seite im iis7 das dotnet komplett abschaltet?
ich vermute
das er dann auch nicht mehr die web.config sucht und mein problem behoben
wàre.

danke für die hilfe!
stefan
 

Lesen sie die antworten

#1 Lutz Elßner
13/07/2009 - 03:29 | Warnen spam

mein problem ist nun das laufend der defaultapp pool abstürzt deswegen.
auffallen tut mir auch, dass der iis7 laufend versucht von dem verknüpften netzlaufwerk die
web.config zu lesen. diese existiert auf dem netzlaufwerk auch nicht.
am liebsten hàtte ich auf dieser seite das dotnet komplett deaktiviert. die seite muss
ja lediglich die png-bilder über http ausliefern.

weis jemand wie man für eine seite im iis7 das dotnet komplett abschaltet? ich vermute



Anwendungspool Grundeinstellungen .Net Framework Version
auf "Kein verwalteter Code" stellen

habe ich aber noch nicht probiert.

Du kannst ja mal berichten was passiert.

Lutz

Ähnliche fragen