Inhalt aus Liste an Makro übergeben?

09/03/2009 - 08:11 von Peter Vogt | Report spam
Hallo NG!
Ich will den Bereich auf Tabelle1 A3:T50 kopieren auf das Tabellenblatt
JANUAR A3:T50
Die Zelle F4 in Tabelle1 hat die Gültigkeit der Daten aus einer Liste.
Ich kann mit der Pulldownliste den jeweiligen Eintrag Januar - Dezember
wàhlen.
Nun soll der Inhalt von F4 dazu dienen, das Tabellenblatt mit gleichem Namen
anzusteuern.
Dazu habe ich auf dem Tabellenblatt den Registernamen JANUAR vergeben und
die Zelle A3 mit dem Namen JANUAR versehen.
Kopiere ich F4 in die Zwischenablage, kann ich zwar das gewünschte Blatt
erreichen, kann aber keinen Inhalt einfügen.
Da hat mich der Makrorecorder verlassen. )-:
Wie kann ich die Kopie auf das gewünschte Blatt erreichen?

Einen schönen Tag noch
Peter Vogt
 

Lesen sie die antworten

#1 Michael Schwimmer
09/03/2009 - 09:18 | Warnen spam
Hallo Peter,

Am Mon, 9 Mar 2009 08:11:38 +0100 schrieb Peter Vogt:
Ich will den Bereich auf Tabelle1 A3:T50 kopieren auf das Tabellenblatt
JANUAR A3:T50
Die Zelle F4 in Tabelle1 hat die Gültigkeit der Daten aus einer Liste.
Ich kann mit der Pulldownliste den jeweiligen Eintrag Januar - Dezember
wàhlen.
Nun soll der Inhalt von F4 dazu dienen, das Tabellenblatt mit gleichem Namen
anzusteuern.
Dazu habe ich auf dem Tabellenblatt den Registernamen JANUAR vergeben und
die Zelle A3 mit dem Namen JANUAR versehen.
Kopiere ich F4 in die Zwischenablage, kann ich zwar das gewünschte Blatt
erreichen, kann aber keinen Inhalt einfügen.
Da hat mich der Makrorecorder verlassen. )-:
Wie kann ich die Kopie auf das gewünschte Blatt erreichen?




wenn ich dich richtig verstanden habe, willst du nur die Werte auf dem
Tabellenblatt 1 sehen?
Dann folgende Formel in A3
=INDIREKT($F$4&"!Z"& ZEILE(A3) &"S"&SPALTE(A3);FALSCH)
Alternativ, wenn Fehlermeldungen unterdrückt werden sollen, etwa bei einem
nicht vorhandenen Blatt:
=WENN(ISTFEHLER(INDIREKT($F$4&"!Z"& ZEILE(A3)
&"S"&SPALTE(A3);FALSCH));"";INDIREKT($F$4&"!Z"& ZEILE(A3)
&"S"&SPALTE(A3);FALSCH))
Anschließend die Zelle rechts unten anpacken und nach rechts bis T4 ziehen.
Da du ja F4, was ja leider in dem auszufüllenden Bereich liegt, nicht
mitüberschreiben willst, markierst du A3:E3 und füllst wie zuvor bis
A50:F50 aus. Das gleiche mit G3:T3, bis G50:T50 ausfüllen. Danach E5:E50
bis F5:F50.
Nun sollte in allen Zellen des Bereichs A3:T50 außer in Zelle F4 die
angepasste Formel stehen.
Gibst du jetzt in F4 einen Blattnamen ein (auch Daten/Gültigkeit/Liste),
zeigen die anderen Zellen die entsprechenden Werte an.

Viele Grüße
Michael


http://michael-schwimmer.de
Masterclass Excel VBA ISBN-10: 3827325250
Das Excel-VBA Codebook ISBN-10: 3827324718
Microsoft Office Excel 2007-Programmierung ISBN-10: 3866454139

Ähnliche fragen