Inhalte (in verschiedenen Zeilen) von Tabellenblättern addieren

14/10/2007 - 16:26 von Markus Löw | Report spam
Hallo NG,

hab folgendes Problem:

Ich möchte den Inhalt von Tabelle1, Tabelle2, ... Tabelle12 in
Tabelle_Zusammenfassung addieren.
Leider geht die 3D-Funktion =SUMME(Tabelle1:Tabelle12!A4) nicht, daß
die Info immer in unterschiedlichen Zeilen anhand von Kundennummern
ausgelesen werden, die jeden Monat anders gerangt sind.

Tabelle Januar
A B
1 Kunde3 100
2 Kunde4 90
3 Kunde1 84

Tabelle Feb
A B
1 Kunde1 120
2 Kunde3 90
3 Kunde2 50

usw

Zusammenfassung
A B
1 Kunde 1 204
3 Kunde 3 190
2 Kunde 4 90
4 Kunde 2 50
Bisher hab ich mich mit einem immer lànger werdenden SVerweis
beholfen, in dem dann für jeden Monat per Sverweis der Wert ausgelesen
und addiert wird.

Frage: Gibt es eine bessere Lösung (per Formel oder VBA)

Danke für eure Unterstützung
Gruß Markus
 

Lesen sie die antworten

#1 {Boris}
14/10/2007 - 16:50 | Warnen spam
Hi Markus,

On 14 Okt., 16:26, Markus Löw wrote:

Ich möchte den Inhalt von Tabelle1, Tabelle2, ... Tabelle12 in
Tabelle_Zusammenfassung addieren.
Leider geht die 3D-Funktion =SUMME(Tabelle1:Tabelle12!A4) nicht, daß
die Info immer in unterschiedlichen Zeilen anhand von Kundennummern
ausgelesen werden, die jeden Monat anders gerangt sind.

Tabelle Januar
A B
1 Kunde3 100
2 Kunde4 90
3 Kunde1 84

Tabelle Feb
A B
1 Kunde1 120
2 Kunde3 90
3 Kunde2 50

usw

Zusammenfassung
A B
1 Kunde 1 204
3 Kunde 3 190
2 Kunde 4 90
4 Kunde 2 50
Bisher hab ich mich mit einem immer lànger werdenden SVerweis
beholfen, in dem dann für jeden Monat per Sverweis der Wert ausgelesen
und addiert wird.

Frage: Gibt es eine bessere Lösung (per Formel oder VBA)



Du kannst eine dreidimensionale Summenformel mit Zusatzbedingung wie
folgt erzeugen:

=SUMMENPRODUKT(SUMMEWENN(INDIREKT("'Tabelle"&ZEILE($1:$12)&"'!
A:A");A1;INDIREKT("'Tabelle"&ZEILE($1:$12)&"'!B:B")))

Summiert die Spalte B der Blàtter "Tabelle1" bis "Tabelle12", wenn
Spalte A mit dem Suchbegriff aus A1 übereinstimmt.
In diesem Fall müssen die Blattnamen indizierbar sein, was ich a)
immer empfehlen würde und b) bei Dir anscheinend eh der Fall ist. Es
geht auch ohne indizierbare Blattnamen, aber das macht die Sache
unnötig kompliziert.

Grüße Boris

Ähnliche fragen