Forums Neueste Beiträge
 

Installation 'failed'

12/02/2011 - 15:41 von Sabine Baer | Report spam
Hallo,
gerade wollte ich (FreeBSD 7.2-STABLE) mit 'portinstall graphics/dia'
das Programm dia installieren, aber nachdem auch munter compiliert
wurde, kam diese Meldung:

|[...]
|/usr/bin/ld: warning: libicui18n.so.38, needed by
|/usr/local/lib/libgtk-x11-2.0.so, not found (try using -rpath or -rpath-link)
|/usr/local/lib/libglib-2.0.so: undefined reference to `u_errorName_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `ucol_strcoll_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `ucol_open_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `ucol_getSortKey_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `u_strFromUTF8_3_8'
|gmake[4]: *** [dia] Error 1
|gmake[4]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1/app'
|gmake[3]: *** [all-recursive] Error 1
|gmake[3]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1/app'
|gmake[2]: *** [all] Error 2
|gmake[2]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1/app'
|gmake[1]: *** [all-recursive] Error 1
|gmake[1]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1'
|gmake: *** [all] Error 2
|*** Error code 1
|
|Stop in /usr/ports/graphics/dia.
|** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall20110212-42831-1xqzkj7-0 env make
|** Fix the problem and try again.
|** Listing the failed packages (-:ignored / *:skipped / !:failed)
| ! graphics/dia (new compiler error)

Ich wuerde das Problem ja gerne fixieren und es nochmal versuchen,
aber
-was ist denn das Problem?
-wie beseitige ich es?

Ratlos,
Sabine

Was glaubst du, was FAQ heißt? Föllig Abstruser Quatsch?
(Hauke Heidtmann in dcouln)
 

Lesen sie die antworten

#1 Heino Tiedemann
12/02/2011 - 17:55 | Warnen spam
Sabine Baer wrote:

Hallo,
gerade wollte ich (FreeBSD 7.2-STABLE) mit 'portinstall graphics/dia'
das Programm dia installieren, aber nachdem auch munter compiliert
wurde, kam diese Meldung:

|[...]
|/usr/bin/ld: warning: libicui18n.so.38, needed by
|/usr/local/lib/libgtk-x11-2.0.so, not found (try using -rpath or -rpath-link)
|/usr/local/lib/libglib-2.0.so: undefined reference to `u_errorName_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `ucol_strcoll_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `ucol_open_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `ucol_getSortKey_3_8'
|/usr/local/lib/libglib-2.0.so: undefined reference to `u_strFromUTF8_3_8'
|gmake[4]: *** [dia] Error 1
|gmake[4]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1/app'
|gmake[3]: *** [all-recursive] Error 1
|gmake[3]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1/app'
|gmake[2]: *** [all] Error 2
|gmake[2]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1/app'
|gmake[1]: *** [all-recursive] Error 1
|gmake[1]: Leaving directory `/usr/ports/graphics/dia/work/dia-0.97.1'
|gmake: *** [all] Error 2
|*** Error code 1
|
|Stop in /usr/ports/graphics/dia.
|** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall20110212-42831-1xqzkj7-0 env make
|** Fix the problem and try again.
|** Listing the failed packages (-:ignored / *:skipped / !:failed)
| ! graphics/dia (new compiler error)

Ich wuerde das Problem ja gerne fixieren und es nochmal versuchen,
aber
-was ist denn das Problem?
-wie beseitige ich es?

Ratlos,
Sabine




nach dem was da steht ist es "/usr/local/lib/libgtk-x11-2.0.so, not
found"

Ist Deine ports collection up to date?

Ist alles der installierten ports up to date?

Heino

Ähnliche fragen