Installation von Ruby sqlite

06/02/2010 - 20:38 von Jörg Klein | Report spam
Hallo,

ich bin gerade dabei Ruby on rails neu zu installieren. Ich habe folgende Pakete vorgesehen:

ruby
ruby-gems
ruby-rails
ruby-sqlite3
ruby-mongrel
ruby-pg

Ich möchte aber postgresql verwenden. Ist es sinnvoll, auch das Paket sqlite3 zu installieren? sqlite3 wird dann als standard
verwendet. Wenn sqlite3 installiert wird, wo konfiguriere ich die zu verwendene Datenbank? Oder besser sqlite3 nicht zu installieren
und nur postgresql verwenden?
Entschuldigt bitte die Anfàngerfragen.

Gruß Joerg
 

Lesen sie die antworten

#1 Andreas Richter
07/02/2010 - 13:47 | Warnen spam
Jörg Klein wrote:

Hallo,



Hi,

ich bin gerade dabei Ruby on rails neu zu installieren. Ich habe folgende
Pakete vorgesehen:

ruby
ruby-gems
ruby-rails
ruby-sqlite3
ruby-mongrel
ruby-pg



Was für Pakete sind das? Die von deinem Betriebssystem? Dann installier
lediglich ruby und rbuy-gems. Rails und alle abhàngigen GEMs bekommst du
dann über

gem install rails

Ich möchte aber postgresql verwenden. Ist es sinnvoll, auch das Paket
sqlite3 zu installieren? sqlite3 wird dann als standard verwendet. Wenn
sqlite3 installiert wird, wo konfiguriere ich die zu verwendene Datenbank?
Oder besser sqlite3 nicht zu installieren und nur postgresql verwenden?
Entschuldigt bitte die Anfàngerfragen.



Wenn mich nicht alles tàuscht, brauchst du SQLite, auch wenn dein
Railsprojekt eine PostgreSQL Datenbank nutzt.

Deine im Projekt verwendeten Datenbanken konfigurierst du in
config/databases.yml


Mit freundlichen Grüssen / With kind regards
Andreas Richter - http://www.anrichter.net
GPG-KeyID: 0x7BA12DD9
Fingerprint: D2E9 202B F4F0 EB16 25DE 5FF7 0CF2 3C57 7BA1 2DD9

Ähnliche fragen