Installieren von einem Dienst

03/12/2008 - 08:25 von Marcel Garaventa | Report spam
Hallo zusammen

Ich möchte einen Dienst installieren und bringe dies nicht fertig. Mein
Dienst heist DienstService und hat im Moment keine Funktion, weil ist die
Installation testen will.

Ich habe auch ein Setup-Programm gemacht und die Primare Ausgabe
hinzugefügt. Dieses làuft auch. Die EXE-Datei wird wie gewünscht in der
Programmordner kopiert. Leider steht mir aber danach der gemachte Dienst in
den Windows Diensten immer noch nicht zur Verfügung.

Ich habe nun meinem Projekt Dienst auch noch ein Installer mit einem
ServiceInstaller und einem ServiceProcessInstaller hinzugefügt und diese
miteinander verknüpft. Trotzdem sege ich den Dienst immer noch nicht.

Weis jemand was ich tun muss, damit mein Dienst auch auch in den
Windows-Diensten erscheint??

Danke für Eure Hilfe
Gruss Marcel
 

Lesen sie die antworten

#1 Marcel Garaventa
03/12/2008 - 13:20 | Warnen spam
Hallo zusammen

Ich habe die Lösung gefunden. Ich schreibe sie hier hin, fals jemand anders
mal dieses Problem haben sollte.

Beim Setup Prokekt muss man Benutzerdefinierte Aktionen hinzufügen. Dazu
klickt man aud Das Setip Projekt rechts und wàhlt Anischt. Im dortigen Menü
wàhlt man Benutzerdefinierte Aktionen.

Dort fügt mal unter Installieren, Rollback und Deinstallieren jeweils die
Primàre Aufgabe hinzu.

Erstellt und installiert man diese Prokekt anschliessen neu, steht der
Dieenst unter den Windows Diensten zur Verfügung.

Gruss Marcel

"Marcel Garaventa" wrote:

Hallo zusammen

Ich möchte einen Dienst installieren und bringe dies nicht fertig. Mein
Dienst heist DienstService und hat im Moment keine Funktion, weil ist die
Installation testen will.

Ich habe auch ein Setup-Programm gemacht und die Primare Ausgabe
hinzugefügt. Dieses làuft auch. Die EXE-Datei wird wie gewünscht in der
Programmordner kopiert. Leider steht mir aber danach der gemachte Dienst in
den Windows Diensten immer noch nicht zur Verfügung.

Ich habe nun meinem Projekt Dienst auch noch ein Installer mit einem
ServiceInstaller und einem ServiceProcessInstaller hinzugefügt und diese
miteinander verknüpft. Trotzdem sege ich den Dienst immer noch nicht.

Weis jemand was ich tun muss, damit mein Dienst auch auch in den
Windows-Diensten erscheint??

Danke für Eure Hilfe
Gruss Marcel

Ähnliche fragen