Intel HD2000 und CentOS 6

15/11/2012 - 12:04 von Jochen Lübbers | Report spam
Hallo,

auf meinem Schreibtisch liegt ein IPC mit "Intel(R) Core(TM) i3-2120T
CPU @ 2.60GHz" CPU. Es soll die "eingebaute" Grafik für eine Darstellung
mit 1280x1024 bei *8-Bit Farbe mit Farbtabelle* genutzt werden. Und da
fangen meine Probleme an:

Der "vesa" Treiber von X11 kann das zwar im Prinzip, aber leider stellt er
um den Maus-Cursor eine helles Recheck dar. (Gleiche Farbe wie der
Hintergrund, aber eben etwas heller.)

Deshalb wolle ich den "intel" Treiber benutzen, in der Hoffnung, dass
dann die Darstellung richtig ist.

Ich habe es allerdings weder mit dem Treiber aus dem RPM
- xorg-x11-drv-intel-2.16.0-4.el6.i686.rpm (von CentOS)
noch mit dem RPM
- xorg-x11-drv-intel-2.20.3-2.el6.elrepo.i686.rpm (von ElRepo)
geschafft, die integrierte Grafik zum laufen zu bringen.

X11 sagt immer:
[ 113.834] (--) PCI:*(0:0:2:0) 8086:0102:15d9:0644 rev 9, Mem @ 0x1e000000/4194304, 0x00000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[...]
[ 113.898] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
Ivybridge Server (GT2)
[ 113.898] (--) using VT number 7

[ 113.951] (EE) No devices detected.
[ 113.951]
Fatal server error:
[ 113.951] no screens found
[ 113.951]

Ist meine Vorstellung falsch, dass diese CPU mit dem "intel"-Treiber
laufen kann, oder was sonst mache ich falsch?
Oder lohnt es den Aufwand nicht, weil der beschriebe Fehler nicht nur im
"vesa"-Treiber steckt?
Oder kann man die Darstellung mit dem "vesa"-Treiber korrigieren?


Ich brauche keine 3D oder HW-Beschleunigung, auf der Kiste soll eine gut
abgehangene Motif-Applikation laufen. Und ein Wechsel auf Truecolor mit
16 oder 24 Bit sind (leider) keine Option.

Danke für eure Bemühungen
Jochen
"Wer die Freiheit aufgibt, um Sicherheit zu gewinnen,
der wird am Ende beides verlieren"
 

Lesen sie die antworten

#1 Dirk Thierbach
15/11/2012 - 17:19 | Warnen spam
Jochen Lübbers wrote:
auf meinem Schreibtisch liegt ein IPC mit "Intel(R) Core(TM) i3-2120T
CPU @ 2.60GHz" CPU. Es soll die "eingebaute" Grafik für eine Darstellung
mit 1280x1024 bei *8-Bit Farbe mit Farbtabelle* genutzt werden. Und da
fangen meine Probleme an:

Der "vesa" Treiber von X11 kann das zwar im Prinzip, aber leider stellt er
um den Maus-Cursor eine helles Recheck dar. (Gleiche Farbe wie der
Hintergrund, aber eben etwas heller.)



Das ist moeglicherweise durch die Farbtabelle bedingt, und evtl. nicht
wegzukriegen.

[ 113.951] (EE) No devices detected.

Ist meine Vorstellung falsch, dass diese CPU mit dem "intel"-Treiber
laufen kann,



Sollte er.

oder was sonst mache ich falsch?



Das passende Kernelmodul (drm, vermutlich i915) ist installiert und geladen?

Oder lohnt es den Aufwand nicht, weil der beschriebe Fehler nicht nur im
"vesa"-Treiber steckt?
Oder kann man die Darstellung mit dem "vesa"-Treiber korrigieren?



Ich kann mir vorstellen, dass ein Software-Cursor bei Pseudocolor
notgedrungen solche Effekte mit sich bringt. Vielleicht kann man es
bei einem Hardware-Cursor vermeiden. Wenn der Intel-Treiber das bei
Pseudocolor unterstuetzt.

Pseudocolor benutzt eigentlich seit Jahren keiner mehr, dashalb ist
die Unterstuetzung wohl eher mau.

Ich brauche keine 3D oder HW-Beschleunigung, auf der Kiste soll eine gut
abgehangene Motif-Applikation laufen. Und ein Wechsel auf Truecolor mit
16 oder 24 Bit sind (leider) keine Option.



Ich hab's noch nicht ausprobiert, aber evtl. kann man mit xnest ein
PseudoColor visual in einem Fenster auf einem Server mit TrueColor
simulieren: "Xnest -class PseudoColor :1" und dann
"AlteMotifApplikation -display :1" oder so.

Keine Ahnung, ob's wirklich geht.

- Dirk

Ähnliche fragen