Invertierender Buck-Boost Konverter

22/09/2009 - 18:51 von Olaf Kaluza | Report spam
Hallo Leute,

Ich brauche mal den Tip des erfahrenen Schaltnetzteilentwicklers.
Und zwar benoetige ich ein Netzteil das mir aus 24V -15V macht,
bei etwa 300mA dauernd, kurzzeitig 500mA.

Mein Auge fiel da auf den LM2576HV als invertierender Buck-boost
Konverter. Siehe auch Datenblatt Seite 18, Schaltung 10.

Das habe ich auch ans laufen gebracht. Allerdings startet die
Schaltung selbst im Leerlauf mit nur 10mA (LED) als Last an meinem
Labornetzteil nicht immer zuverlaessig. Der Grund dafuer ist das mein
Netzteil nur 2.5A liefert und das sehr knapp ist. Wenn ich gar einen
33Ohm Widerstand als Last am Ausgang habe startet das mit dem Netzteil
garnicht.
Das Problem laesst sich loesen indem ich am Ausgang des Laborneteils
noch einen Elko haenge. Ich hab mal 10000uF genommen weil der gerade
so rumlag.

Mit anderen Worten die Schaltung zieht einen tierischen
Einschaltstrom. Das Problem laesst sich vermutlich umgehen indem ich
eine Einschaltverzoegerung an den Schaltregler baue der den Regler
erst einschaltet wenn ein Elko am Eingang sicher geladen
ist. Jedenfalls wird das im Datenblatt vorgeschlagen

Ist das in der Praxis akzeptabel, oder gibt es ein anderes
Reglerkonzept das fuer diese Aufgabe besser geeignet ist?

Was mir ein bisschen Sorgen macht ist das Verhalten der Schaltung im
Problemfall. Dann ist der Transistor im Schaltregler naemlich
dauerhaft durchgeschaltet und glueht alles ordentlich durch.

Olaf
 

Lesen sie die antworten

#1 Joerg
22/09/2009 - 19:45 | Warnen spam
Olaf Kaluza wrote:
Hallo Leute,

Ich brauche mal den Tip des erfahrenen Schaltnetzteilentwicklers.
Und zwar benoetige ich ein Netzteil das mir aus 24V -15V macht,
bei etwa 300mA dauernd, kurzzeitig 500mA.

Mein Auge fiel da auf den LM2576HV als invertierender Buck-boost
Konverter. Siehe auch Datenblatt Seite 18, Schaltung 10.




LM2576 mit 50kHz? <gaehn ... does ... vom_Stuhl_kipp>


Das habe ich auch ans laufen gebracht. Allerdings startet die
Schaltung selbst im Leerlauf mit nur 10mA (LED) als Last an meinem
Labornetzteil nicht immer zuverlaessig. Der Grund dafuer ist das mein
Netzteil nur 2.5A liefert und das sehr knapp ist. Wenn ich gar einen
33Ohm Widerstand als Last am Ausgang habe startet das mit dem Netzteil
garnicht.




Diese ollen Dinger brauchen einige hundert uF am Ausgang und die will er
erstmal aufladen, und zwar prontissimo. Dabei verschluckt sich
vermutlich Dein Labornetzteil, geht in den Foldback oder so. Nun geht
das Spielchen u.U. immer wieder von vorn los.


Das Problem laesst sich loesen indem ich am Ausgang des Laborneteils
noch einen Elko haenge. Ich hab mal 10000uF genommen weil der gerade
so rumlag.

Mit anderen Worten die Schaltung zieht einen tierischen
Einschaltstrom. Das Problem laesst sich vermutlich umgehen indem ich
eine Einschaltverzoegerung an den Schaltregler baue der den Regler
erst einschaltet wenn ein Elko am Eingang sicher geladen
ist. Jedenfalls wird das im Datenblatt vorgeschlagen




Nicht alles in Datenblaettern bierernst nehmen :-)


Ist das in der Praxis akzeptabel, oder gibt es ein anderes
Reglerkonzept das fuer diese Aufgabe besser geeignet ist?




Ein Regler-Chip mit Softstart (wichtig!), wesentlich hoehere Frequenz.
300-500kHz ist heute Stand der Technik, >1MHz bei modernen Sachen. Dann
braucht man weniger Kapazitaet am Ausgang. Es muss aber ein Chip sein wo
sie die Loop nicht vergurkt haben und der dann doch fette OSCON braucht.
Von Simple-Switchers halte ich nicht viel, LTC ist da IMHO die beste
Adresse. Die haben auch gescheite Simulatormodelle und wir koennten Dir
helfen das zusammen zu schustern.

Kruecke, wenn Du diesen Regler Marke Methusalem behalten moechtest,
wesentlich besser als den vorgeschlagenen fetten Elko rein zu friemeln:
FB per Widerstand von einer postiven Quelle (Eingang) auf 1.2V oder mehr
hochziehen, aber bei drei Diodenstrecken oder so klemmen. Nach
Einschalten langsam wegnehmen, dann kommt er sachte.


Was mir ein bisschen Sorgen macht ist das Verhalten der Schaltung im
Problemfall. Dann ist der Transistor im Schaltregler naemlich
dauerhaft durchgeschaltet und glueht alles ordentlich durch.




Das ist leider bei allen Durchschaltern so. Aber selbst ein SEPIC kann
"durchgehen", wenn die Loop abgeht oder so. Wenn was teures dranhaengt
gibt's nix, da muss eine Crowbar rein.

Gruesse, Joerg

http://www.analogconsultants.com/

"gmail" domain blocked because of excessive spam.
Use another domain or send PM.

Ähnliche fragen