IO Charset UTF-8 missing

26/01/2016 - 21:29 von Marc Haber | Report spam
Hi,

ich habe hier einen seit jahren nicht mehr eingehàngten USB-Stick mit
einem FAT-Filesystem:

|$ sudo file -sL /dev/sdc1
|/dev/sdc1: sticky x86 boot sector, mkdosfs boot message display, code offset 0x58, OEM-ID " mkdosfs", sectors/cluster 8, Media descriptor 0xf8, heads 61, sectors 3860478 (volumes > 32 MB) , FAT (32 bit), sectors/FAT 3768, serial number 0xe87c28af, label:

Wenn ich den versuche einzuhàngen, funktioniert es nicht:

|$ sudo mount -t vfat /dev/sdc1 /media/bootstick/
|mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
| missing codepage or helper program, or other error
| In some cases useful info is found in syslog - try
| dmesg | tail or so
|
|$ dmesg | tail -n 1
|FAT-fs (sdc1): IO charset UTF-8 not found
|$ sudo lsmod | grep utf8
|nls_utf8 1448 0
|$

Wie Ihr seht, ist nls_utf8 geladen. Was kann denn da noch für ein
Kernelmodul fehlen?

Grüße
Marc
Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " | http://www.zugschlus.de/
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834
 

Lesen sie die antworten

#1 Michael Baeuerle
26/01/2016 - 22:37 | Warnen spam
Marc Haber wrote:

ich habe hier einen seit jahren nicht mehr eingehàngten USB-Stick mit
einem FAT-Filesystem:

|$ sudo file -sL /dev/sdc1
|/dev/sdc1: sticky x86 boot sector, mkdosfs boot message display, code offset 0x58, OEM-ID " mkdosfs", sectors/cluster 8, Media descriptor 0xf8, heads 61, sectors 3860478 (volumes > 32 MB) , FAT (32 bit), sectors/FAT 3768, serial number 0xe87c28af, label:

Wenn ich den versuche einzuhàngen, funktioniert es nicht:

|$ sudo mount -t vfat /dev/sdc1 /media/bootstick/
|mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
| missing codepage or helper program, or other error
| In some cases useful info is found in syslog - try
| dmesg | tail or so
|
|$ dmesg | tail -n 1
|FAT-fs (sdc1): IO charset UTF-8 not found
|$ sudo lsmod | grep utf8
|nls_utf8 1448 0
|$

Wie Ihr seht, ist nls_utf8 geladen. Was kann denn da noch für ein
Kernelmodul fehlen?



Zu den Kerneltreibern kann ich nichts konkretes sagen, aber hast du mal
versucht das FS als herkömmliches FAT (also nur mit den kurzen Datei-
namen) zu mounten?
"-t msdos" war das IIRC. Nur um zu sehen ob es sich da anders verhàlt.
Sorry, aber mit der Einstellung würden wir heute aus Sicherheitsgründen
noch auf dem Baum sitzen. Wer etwas Neues schaffen will, muß auch was
wagen - aber da heute Kinder schon zu Fuß mit Helm rumlaufen gilt das
wohl nicht mehr... [Eric Brücklmeier in dse]

Ähnliche fragen