ISA und der Weihnachtsmann im Februar...

28/02/2008 - 17:53 von Roland Messerschmidt | Report spam
Hallo allerseits!

Ein eher kosmetisches Problem, aber trotzdem wàre es interessant, wie
es dazu kommt:

(Internet - SBS2003 Premium mit ISA2004 - Clients)

Ich besuche regelmàßig eine Internetseite meines
"Lieblingsurlaubsdorfes", auf der - wie nicht unüblich - im
Headerbereich ein Foto eingebunden ist. In der Weihnachtszeit wurde
nun dieses Foto noch mit Weihnachtsmann samt Schlitten versehen.

Anfang Jànner dachte ich mir noch, daß sich der "Abflug" des
Weihnachtsmannes möglicherweise durch einen Urlaub des Webmasters
verzögere, aber nun fast am Ende des Februars kam mir diese Erklàrung
doch spanisch (oder besser norwegisch... ;-) ) vor, zumal
Ankündigungen etc. aktuell gehalten werden.

Irgendwann kam mir die Idee: klar, der IE hat ja einen Cache, das wird
das Problem sein.
Reload gedrückt, Weihnachtsmann weg. Thema erledigt.
Oder nicht ganz.
Neuer Aufruf der Seite - Weihnachtsmann ist wieder da!
Reload - Weinachtsmann weg...

Kürzlich habe ich einen PC neu aufgesetzt, die Seite aber noch nie
nach der Installation aufgerufen. Also auf diesem PC probiert -
Weihnachtsmann da! (Also insgesamt auf 2x XP und 1x Vista getestet.)

Mit Test-PC ISA-Server umgangen - kein Weihnachtsmann.

Somit ist klar: Der Weihnachtsmann muß also irgendwo im ISA sitzen...
;-)

Was mich nun wundert: Warum wird im ISA-Cache nicht die Seite
aktualisiert, wenn ich sie im Browser (mit und ohne gedrückter
Strg-Taste) offensichtlich aktualisiere?

Und warum hat vor Weihnachten das neue Foto in den ISA-Cache gefunden,
nach Weihnachten aber nicht mehr?

Und schließlich: wie wird man den Weihnachtsmann wieder los? ;-) (Ich
vermute einmal, einfach den ISA-Cache löschen...)


Danke im voraus für eure Meinungen!


Roland
 

Lesen sie die antworten

#1 Hardy Elis
01/03/2008 - 14:27 | Warnen spam
Hallo Roland!

Das Problem wird der TTL-Wert dieser Webseite sein, sprich der Wert, der bei
der Seitenprogrammierung normalerweise mit einprogrammiert wird, der
vorgibt, wie lange diese Seite im Cache vorgehalten werden soll bzw. kann.
Durch aktualisierung des Browsers muß die Seite vom Webserver neu geladen
werden. Deshalb ist die Seite dann aktuell. Entweder ist der ISA an dieser
Stelle falsch konfiguriert oder die Seite beinhaltet einen Fehler. Wir
verwenden keinen ISA sondern einen Proxy (non Transparent) bei dem man diese
TTL-Werte für jede oder für alle Seiten konfigurieren kann. Solch ein
Problem hatten wir genau dabei auch einmal.
Schau mal ob du dem ISA beibringen kannst, dass er entweder einen "immer
standard-TTL" verwenden soll oder einen "standard-TTL wenn keiner bekannt
ist". So haben wir den Fehler gelöst.

Gruß
Hardy

"Roland Messerschmidt" schrieb im Newsbeitrag
news:
Hallo allerseits!

Ein eher kosmetisches Problem, aber trotzdem wàre es interessant, wie es
dazu kommt:

(Internet - SBS2003 Premium mit ISA2004 - Clients)

Ich besuche regelmàßig eine Internetseite meines "Lieblingsurlaubsdorfes",
auf der - wie nicht unüblich - im Headerbereich ein Foto eingebunden ist.
In der Weihnachtszeit wurde nun dieses Foto noch mit Weihnachtsmann samt
Schlitten versehen.

Anfang Jànner dachte ich mir noch, daß sich der "Abflug" des
Weihnachtsmannes möglicherweise durch einen Urlaub des Webmasters
verzögere, aber nun fast am Ende des Februars kam mir diese Erklàrung doch
spanisch (oder besser norwegisch... ;-) ) vor, zumal Ankündigungen etc.
aktuell gehalten werden.

Irgendwann kam mir die Idee: klar, der IE hat ja einen Cache, das wird das
Problem sein.
Reload gedrückt, Weihnachtsmann weg. Thema erledigt.
Oder nicht ganz.
Neuer Aufruf der Seite - Weihnachtsmann ist wieder da!
Reload - Weinachtsmann weg...

Kürzlich habe ich einen PC neu aufgesetzt, die Seite aber noch nie nach
der Installation aufgerufen. Also auf diesem PC probiert - Weihnachtsmann
da! (Also insgesamt auf 2x XP und 1x Vista getestet.)

Mit Test-PC ISA-Server umgangen - kein Weihnachtsmann.

Somit ist klar: Der Weihnachtsmann muß also irgendwo im ISA sitzen... ;-)

Was mich nun wundert: Warum wird im ISA-Cache nicht die Seite
aktualisiert, wenn ich sie im Browser (mit und ohne gedrückter Strg-Taste)
offensichtlich aktualisiere?

Und warum hat vor Weihnachten das neue Foto in den ISA-Cache gefunden,
nach Weihnachten aber nicht mehr?

Und schließlich: wie wird man den Weihnachtsmann wieder los? ;-) (Ich
vermute einmal, einfach den ISA-Cache löschen...)


Danke im voraus für eure Meinungen!


Roland


Ähnliche fragen