ISA06 HTTPS Tunnelingproblem mit Zertifikat

15/05/2008 - 18:17 von Roger Hungerbuehler | Report spam
Hallo

Hab da wiedermal ein fuer mich seltsames Problem:

Kunde hat einen Webserver (IIS6) in der DMZ.
Auf dem Webserver laufen zwei DBs, welche von externen Kunden
verwendet werden.
Die externen Kunden stellen eine HTTPS-VErbindung zum Webserver her
und muessen sich dort ertsmal am IIS mittles lokaler Konten anmelden.

Wir haben ein kommerzielles Webserver Zertifikat von
www.ssl-zertifikat.ch welches ich auf dem IIS installiert habe, dann
habe ich dieses exportiert und am ISA ebenfalls installiert.
Da beim ISA die uebergerodneten Zertifikate im flaschen Container
landeten, habe ich dies korrigiert und in die richtigen Container
(Compuerkonto: Vertrausenwuerdige Stammzertifizierungsstellen und
Computerkonto: Zwischenzertifizierungsstellen) importiert.

Nun zum Problem, wenn ich die Website mit dem IE aufrufe klappt alles
wunderbar, mit allen anderen Browsern (Firefox usw.) dagegen gehts
schief, weil diese offenbar die uebergerordneten Zertifikate nicht
findet.

Gemaess dem Support von www.ssl-zertifikat.ch liegt das Problem wie
gesagt an den uebergeordneten Zertifikaten, aber owschon ich diese
exakt nach Anweisung installiert habe, geht es nur mit IE, weil dieser
offenbar (im Gegensatz zu den anderen Browsern) wohl diese Zertifikate
online abrufen kann.

Ich hoffe, ich habe mich halbwegs verstaendlich ausgedrueckt :-)

Gruss
Roger Hungerbuehler
 

Lesen sie die antworten

#1 Jens Mander
15/05/2008 - 20:57 | Warnen spam
hai roger,
wenn ich das richtig in erinnerung habe, dann hat der firefox einen eigenen
zertifikatsspeicher (andere browser wahrscheinlich auch).
ein flotter gegentest bei mir in der vm bestàtigt das. ich habe das
zeritifzierungsinstanzzertifikat in meinen lokalen
computerzertifikatsspeicher unter vertrauenswürdige
stammzertifizierungsstellen hinterlegt und der zugriff via ie7 klappt
wunderbar auf eine website, die von meiner instanz ein webserverzertifikat
vorher verpasst bekommen hat. versuche ich nun mit dem ff drauf zuzugreifen
ist essig. er meckert an, das er der ca nicht vertrauen würde. ich kann es
nun im ff-dialog allerdings auf "immer akzeptieren" stellen und gut ist.
allerdings bin ich dann den schritt gegangen hier ebenfalls das
zertifizierungsinstanzzertifikat in die vertrauenswürdigen
stammzertifizierungsstellen zu importieren (bei ff: extras / einstellungen /
erweitert / verschlüsselung / zertifikate anzeigen / zertifizierungsstellen
/ importieren) und siehe da seitdem meckert der ff beim https-zugriff nicht
mehr.
hoffe das hilft dir weiter.
gruss, jens mander...



"Roger Hungerbuehler" schrieb im Newsbeitrag
news:
Hallo

Hab da wiedermal ein fuer mich seltsames Problem:

Kunde hat einen Webserver (IIS6) in der DMZ.
Auf dem Webserver laufen zwei DBs, welche von externen Kunden verwendet
werden.
Die externen Kunden stellen eine HTTPS-VErbindung zum Webserver her und
muessen sich dort ertsmal am IIS mittles lokaler Konten anmelden.

Wir haben ein kommerzielles Webserver Zertifikat von www.ssl-zertifikat.ch
welches ich auf dem IIS installiert habe, dann habe ich dieses exportiert
und am ISA ebenfalls installiert.
Da beim ISA die uebergerodneten Zertifikate im flaschen Container
landeten, habe ich dies korrigiert und in die richtigen Container
(Compuerkonto: Vertrausenwuerdige Stammzertifizierungsstellen und
Computerkonto: Zwischenzertifizierungsstellen) importiert.

Nun zum Problem, wenn ich die Website mit dem IE aufrufe klappt alles
wunderbar, mit allen anderen Browsern (Firefox usw.) dagegen gehts schief,
weil diese offenbar die uebergerordneten Zertifikate nicht findet.

Gemaess dem Support von www.ssl-zertifikat.ch liegt das Problem wie gesagt
an den uebergeordneten Zertifikaten, aber owschon ich diese exakt nach
Anweisung installiert habe, geht es nur mit IE, weil dieser offenbar (im
Gegensatz zu den anderen Browsern) wohl diese Zertifikate online abrufen
kann.

Ich hoffe, ich habe mich halbwegs verstaendlich ausgedrueckt :-)

Gruss
Roger Hungerbuehler


Ähnliche fragen