Ist segfault immer ein Hardwareproblem?

14/01/2010 - 17:57 von Peter Blancke | Report spam
Guten Abend,

auf einem Fernrechner (Debian/Lenny, Linux 2.6.26-2-amd64), den ich
nicht in die Finger kriege und auf welchem ich vorerst Memtest nicht
ausfuehren kann, kriegte ich heute einige Male folgende Meldung:

,-[ Aus: /var/log/kern.log: ]
| Jan 14 12:03:25 server kernel:
| [3881564.323996] apache2[29945]:
| segfault at 7fff1c85a2dc
| ip 7f838258ea2f
| sp 7fff1c85a2d0
| error 6 in libphp5.so[7f83822e2000+587000]
`-

Musz so etwas grundsaetzlich ein Hardwareproblem sein oder kann eine
solche Meldung im Kernel unter widrigen Umstaenden auch durch
Software ausgeloest werden?

Jemand installierte auf obigem Server einen Webshop (Bezeichnung
habe ich noch nicht). Bei Aufruf dieses Shops wird reproduzierbar
diese Meldung erzeugt. Vorher gab es solche Meldungen nicht.

Der Server hat 12 GB RAM.

Anmerkung:

Ich hatte gestern einen anderen Server mit 4 GB RAM, auf dem es auch
"segfaults" und irgendwann auch komplette Abstuerze gab. Memtest
zeigte keine defekten Bereiche im RAM an. Ich habe den RAM dann doch
einmal ausgetauscht (allerdings nur gegen 2 GB) und danach waren
diese Meldungen weg.

Grusz,

Peter Blancke

Hoc est enim verbum meum!
 

Lesen sie die antworten

#1 Wilhelm C. Schütze
14/01/2010 - 19:05 | Warnen spam
Am Thu, 14 Jan 2010 16:57:43 +0000 (UTC)
schrieb Peter Blancke :


Musz so etwas grundsaetzlich ein Hardwareproblem sein oder kann eine
solche Meldung im Kernel unter widrigen Umstaenden auch durch
Software ausgeloest werden?



Die Frage ist, was du unter einem Hardwareproblem verstehst. Es reicht,
dass die Hardware nicht so funktioniert, wie die Software es erwartet,
obwohl die Hardware an sich völlig fehlerfrei ist. Dazu reicht es auch,
das ist nach meiner Erfahrung der hàufigste Fall, bei der
Softwareerstellung eine veraltete lib zu verwenden. Kleine
Unvertràglichkeiten in den Softwareschnittstellen der
Speicherverwaltung lösen durchaus eine Schutzverletzung aus.

Jemand installierte auf obigem Server einen Webshop (Bezeichnung
habe ich noch nicht). Bei Aufruf dieses Shops wird reproduzierbar
diese Meldung erzeugt. Vorher gab es solche Meldungen nicht.



Ich hatte auch schon den Fall, dass ein "hinteres" Speichermodul defekt
war, also der Speicher an einer Adresse defekt war, die nur bei
sehr hohem "Füllstand" benutzt wird, im "Leerlauf" aber unauffàllig
blieb. Aber hier würde ich eher memtest trauen und erst mal die genauen
Installationsbedingungen der Webshopsoftware nachprüfen.

Grüße - Wilhelm

Ähnliche fragen