ISTLEER() liefert unterschiedliche Werte

01/10/2007 - 13:21 von Rene Langer | Report spam
Hallo an alle,

habe folgendes Problem das ich anhand eines kleinen Beispiels erklàren
möchte:

Zelle A1 ist leer
Zelle B1 enthàlt die einfach Zuweisung "¡" (interessanterweise steht da
dann ein Nuller als Formelergebnis drin)


ISTLEER(A1) liefert WAHR
ISTLEER(B1) liefert FALSCH

auch der Vergleich

¡="" liefert WAHR
±="" liefert FALSCH

warum ist das so, und wie kann ich das umgehen?



Danke,

Rene
 

Lesen sie die antworten

#1 Claus Busch
01/10/2007 - 13:29 | Warnen spam
Hallo Rene,

Am Mon, 1 Oct 2007 13:21:31 +0200 schrieb Rene Langer:

habe folgendes Problem das ich anhand eines kleinen Beispiels erklàren
möchte:

Zelle A1 ist leer
Zelle B1 enthàlt die einfach Zuweisung "¡" (interessanterweise steht da
dann ein Nuller als Formelergebnis drin)

ISTLEER(A1) liefert WAHR
ISTLEER(B1) liefert FALSCH

auch der Vergleich

¡="" liefert WAHR
±="" liefert FALSCH



die Formel ¡ nimmt sich den *Wert* aus A1 und der ist nun mal 0, wenn in
der Zelle nichts steht.
Du könntest es umgehen mit:
=WENN(A1="";"";A1)


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen