jessie, cryptsetup, swap und systemd

16/02/2016 - 00:50 von Juergen Christoffel | Report spam
Hi all,

da ich vor kurzem eine Maschine mit einer neuen SSD erweiter habe, habe ich
den zusàtzlichen Platz heute mal genutzt, um mit Debian 8 und systemd etwas
zu experimentieren. Bisher komme ich mit Debian 7 noch ganz gut aus.

Das neue System habe ich verschlüsselt aufgesetzt, auch swap ist
verschlüsselt. Nun fragt mich das System beim Start nicht nur nach dem Key
für /, sondern immer auch nach dem Key für Swap, was früher nicht der Fall
war.

Aufgesetzt habe ich das System mit manueller Partitionierung. Nicht zuletzt
deshalb, weil Debian-Install immer die ganze Platte überschreiben will,
auch wenn sie neu ist. Da das Zeit bei 1TB reichlich Zeit braucht und da
man ja SSDs nicht unnötig bis zum Anschlag voll schreiben soll, also
manuell mit

/boot als ex4, unverschlüsselt

/ verschlüsselt, probeweise btrfs

swap verschlüsselt

Das manuelle Partitionieren verlangte auch für das Swap-Device eine
Passphrase, vermutlich weil's beim Verschlüsseln noch nicht weiss, dass es
Swap wird.

Die Eintràge in /etc/crypttab sehen aus wie bei Debian 7, also sollte der
Key "on the fly" und zufàllig sein, aber beim Booten werde ich nun nach der
Passphrase erst für / und dann für Swap gefragt. Wer macht das (initrd?)
und wie gewöhne ich ihm das ab?

Für sachdienliche Hinweise dankt, JC


I don't care about bloat because it's inefficient. I care about it
because it makes the web inaccessible. Keeping the Web simple keeps it
awesome.
 

Lesen sie die antworten

#1 Helmut Backhaus
16/02/2016 - 01:40 | Warnen spam
Hallo Jürgen,

Am 16.02.2016 um 00:27 schrieb Juergen Christoffel:
Aufgesetzt habe ich das System mit manueller Partitionierung. Nicht
zuletzt
deshalb, weil Debian-Install immer die ganze Platte überschreiben will,
auch wenn sie neu ist. Da das Zeit bei 1TB reichlich Zeit braucht und da
man ja SSDs nicht unnötig bis zum Anschlag voll schreiben soll, also
manuell mit
/boot als ex4, unverschlüsselt

/ verschlüsselt, probeweise btrfs

swap verschlüsselt


Schau mal ob die Partition wirklich den Typ 82 hat.
Oder ob der Installer sie wieder auf 83 gesetzt hat und sie jetzt
/swap heißt und ext4 hat.

Das ist mir vor kurzem 3 mal hintereinander passiert, bis ich dahinter
kam das beim setzen der Verschlüsselung der Typ auf 83 (linux) gesetzt wird.
Also erst Verschlüsselung und dann Typ 82 (linux swap) setzen, dann gehts!


Das manuelle Partitionieren verlangte auch für das Swap-Device eine
Passphrase, vermutlich weil's beim Verschlüsseln noch nicht weiss,
dass es
Swap wird.


Das hat sich bei mir genauso dargestellt.
Schau mal, ich bin nicht sicher (ich kann es gerade nicht probieren),
aber es könnte sein.

Gruß,
Helmut Backhaus

Ähnliche fragen