Kalendersteuerelement mal wieder ;-)

05/06/2008 - 20:12 von jensspeedy | Report spam
ich war auf der suche nach nem Kalendersteuerelement und bin hier
fündig geworden
http://www.fontstuff.com/word/wordtut03a.htm - mir als newbie sei es
verziehen ;-)

wenn ich die herunterladbare *dot-Datei offne dann funktioniert auch
alles wunderbar - baue ich allerdings den code in meine *.dot ein
(dort aber mit "Document_new" und nicht wie beiŽm Beispiel
"Document_open" dann kommt mein "fast" ganzer restlicher Code
durcheinander

so findet er plötzlich bei

Set objDBEngine = CreateObject("DAO.DBEngine.36")
Set objDBEngine = OpenDatabase("C:\z_vorlagen\zzz_db
\Datenbank1.mdb")
Set objRS = objDBEngine.OpenRecordset("SELECT * FROM z_adressen "
& _
"WHERE D010Nr=" & Nummer &
" " & _
"AND D060Nr=" & Nummer2,
_
dbOpenDynaset, dbSeeChanges)

im Bereich objDBEngine.OpenRecordset das "OpenRecordset" nicht mehr -
der Debugger kommt gerannt und sagt
"Methode oder Datenobjekt nicht gefunden"

ohne das Kalendersteuerelement funktioniert allerdings alles bestens -
ok ok ich gebe es zu - wàre nur nen witziges Gimmik was ich noch in
die Vorlage einbauen könnte aber "eigentlich" müßte es doch
funktionieren - die herunterladbare *.dot funktioniert zumindest
tadellos auf allen ausprobierten Rechnern

Muss ich eventuell etwas deklarieren oder so - weil beim ersten
ausprobieren kam auch der Fehler in einer For-Next Schleife dass "i"
nicht deklariert sei - dies konnte ich aber mit "Dim i As Long" aus
der Welt schaffen - ohne Kalendersteuerelement hatte es auch ohne dies
funktioniert?

Hat einer der Wissenden unter Euch eine Idee woran das nun wieder
liegen könnte?

viele Grüße aus Berlin - der Jens
 

Lesen sie die antworten

#1 Hartwig Constien
09/06/2008 - 08:53 | Warnen spam
Hallo Jens,

... wenn ich die herunterladbare *dot-Datei offne dann funktioniert auch
alles wunderbar - baue ich allerdings den code in meine *.dot ein
(dort aber mit "Document_new" und nicht wie bei´m Beispiel
"Document_open" dann kommt mein "fast" ganzer restlicher Code
durcheinander



hast du denn auch den nötigen Verweis in Deiner eigenen Vorlage eingetragen?
Siehe in VBA unter Extras, Verweise. Fehlende Verweise können durchaus der
Grund für unerwartete und unspezifische Fehlermeldungen sein. Und wenn Du in
allen Deklarationsteilen Option Explicit verwendest, rutscht Dir auch keine
undefinierte Variable mehr durch.

Hang loose, Hartwig

Ähnliche fragen