Kalenderwoche

21/01/2008 - 10:19 von Marcus Friebe | Report spam
Hallo
Ich denke Ihr könnt mir vielleicht weiter helfen bei meinem kleinen
Problem.
In meiner Tabelle steht in der Spalte (A2:A32) das Datum des jeweiligen
Monats. Also 01.Januar 2008 bis 31.Januar 2008. Im Tabellenblatt Februar
das selbe, nur sind hier logischer Weise die Zellen A31 & A32 nicht
belegt, weil der Monat ja nur 29 Tage hat. Nun zu meinem eigentlichen
Problem. Ich berechne in der Spalte G2:G32 mit folgender Funktion die
KW.
=WENN(WOCHENTAG(A2;2)=1;KALENDERWOCHE(A2;2);" ")
Nur habe ich hier das Problem das Excel mir z.B. im Tabellenblatt für
den Februar in den Zellen G31 & G32 den Fehler ("#WERT) ausgibt weil
natürlich hier in der Spalte A kein Wochentag zu finden ist.
Habt Ihr vielleicht eine elegante Lösung für mich, ich sehe den Wald
schon vor lauter Bàumen nicht mehr :-)
Mit freundlichen Grüßen
Marcus Friebe
 

Lesen sie die antworten

#1 Claus Busch
21/01/2008 - 13:07 | Warnen spam
Hallo Marcus,

"Marcus Friebe" wrote:

Ich denke Ihr könnt mir vielleicht weiter helfen bei meinem kleinen
Problem.
In meiner Tabelle steht in der Spalte (A2:A32) das Datum des jeweiligen
Monats. Also 01.Januar 2008 bis 31.Januar 2008. Im Tabellenblatt Februar
das selbe, nur sind hier logischer Weise die Zellen A31 & A32 nicht
belegt, weil der Monat ja nur 29 Tage hat. Nun zu meinem eigentlichen
Problem. Ich berechne in der Spalte G2:G32 mit folgender Funktion die
KW.
=WENN(WOCHENTAG(A2;2)=1;KALENDERWOCHE(A2;2);" ")
Nur habe ich hier das Problem das Excel mir z.B. im Tabellenblatt für
den Februar in den Zellen G31 & G32 den Fehler ("#WERT) ausgibt weil
natürlich hier in der Spalte A kein Wochentag zu finden ist.
Habt Ihr vielleicht eine elegante Lösung für mich, ich sehe den Wald
schon vor lauter Bàumen nicht mehr :-)



zuerst einmal, Kalenderwoche rechnet nach US-Standard und der stimmt nicht
mit der DIN-Norm überein.
Probiere es dann mal so:
=WENN(A2="";"";KÜRZEN((A2-DATUM(JAHR(A2+3-REST(A2-2;7));1;REST(A2-2;7)-9))/7))

Mit freundlichen Grüssen
Claus Busch
@Web-Interface

Windows XP SP2
Office 2000 SP3

Ähnliche fragen