Kann ich in einer WENN-Formel eine SUB aufrufen

25/09/2007 - 08:25 von Gelbmann Stephan | Report spam
Hallo,
ich möchte in einer WENN - Formel eine SUB Berechen aufrufen.
Bekomme ich nicht hin.

Sub Berechne()
x=y*2
end Sub

Die WENN sollte so aussehen: =WENN(Wert>100;call Berechne();"OK")
Leider geht es so nicht.
Wie geht es richtig?
Gruß Stephan
 

Lesen sie die antworten

#1 Hajo_Zi
25/09/2007 - 09:06 | Warnen spam
Hallo Stephan,

ein Makro nicht aber eine Funktion.
Über wenn Makro starten
Du musst dazu einen Umweg anlegen.
Die WENN-Funktion lautet z.B.
=WENN(A1>10;MakroStart();"Nix")
Die Wenn-Bedingung kann kein Makro starten, aber eine Funktion ausführen.
Diese Funktion kann wiederum ein Makro aufrufen.
Die Funktion ist so aufgebaut und ruft das abhàngige Makro auf:
Function MakroStart()
Application.Volatile
MakroStart_Makro
End Function
Sub MakroStart_Makro()
MsgBox ("TuT")
End Sub

Gruß Hajo
MVP für Microsoft Excel
Betriebssystem Vista Ultimate und Excel Version2007
http://Hajo-Excel.de/



"Gelbmann Stephan" wrote:

Hallo,
ich möchte in einer WENN - Formel eine SUB Berechen aufrufen.
Bekomme ich nicht hin.

Sub Berechne()
x=y*2
end Sub

Die WENN sollte so aussehen: =WENN(Wert>100;call Berechne();"OK")
Leider geht es so nicht.
Wie geht es richtig?
Gruß Stephan

Ähnliche fragen