Forums Neueste Beiträge
 

Kann plötzlich nicht mehr in die Ereignisanzeige schreiben (C# 2.0)

18/12/2007 - 16:50 von Ralf Christoff | Report spam
Hallole,

ich hab 2 Dienste auf einem Windows XP SP2 PC laufen.
Plötzlich sind die Dienste abgeschmiert und ich konnte Sie nicht mehr
starten.
Ich hab herausgefunden das es daran liegt das meine Dienste beim starten
in die Ereignisanzeige(Anwendungsprotokoll) ein paar Info's schreiben
(Version, Benutzer...)
Wenn ich dieses "Schreiben in die Ereignisanzeige" ausklammere, kann ich
meine Dienste wieder
starten. Die Dienste laufen im Kontext des Admins und liefen bisher auch 2
Wochen ohne Probleme.
Ich hatte das vor ca. 4 Wochen schonmal. Ich hab nix gefunden und den PC
komplett neu installiert.
Aber das kanns ja net sein das ich das schon wieder machen muß :(
Ich schreib so in die Ereignisanzeige:
EventLog.WriteEntry("myService", "irgendnen_Text",
EventLogEntryType.Information);

Ich hab alle aktuellen Patch's drauf die momentan verfügbar sind.

danke,
gruss,
Ralf
 

Lesen sie die antworten

#1 Sascha Fueller
19/12/2007 - 07:47 | Warnen spam
Hallo Ralf,

das liegt daran, dass das Ereignisprotokoll voll ist. Das führt dazu, dass
beim Schreiben eine Exception geliefert wird. normalerweise werden Meldungen
erst wieder überschrieben, wenn sie àlter wie sieben Tage sind.


Mögliche Lösungen:
- behandeln der Exception (sollte auf jeden Fall sein)
- Einstellungen der Ereignisanzeige àndern.
- öffnen der Ereignisanzeige
- Eigenschaften von "Anwendungen" auswàhlen
- dort die Protokollgröße und / oder das Verhalten bei vollem Protokoll
anpassen

Gruß
Sascha

"Ralf Christoff" schrieb im Newsbeitrag
news:
Hallole,

ich hab 2 Dienste auf einem Windows XP SP2 PC laufen.
Plötzlich sind die Dienste abgeschmiert und ich konnte Sie nicht mehr
starten.
Ich hab herausgefunden das es daran liegt das meine Dienste beim starten
in die Ereignisanzeige(Anwendungsprotokoll) ein paar Info's schreiben
(Version, Benutzer...)
Wenn ich dieses "Schreiben in die Ereignisanzeige" ausklammere, kann ich
meine Dienste wieder
starten. Die Dienste laufen im Kontext des Admins und liefen bisher auch 2
Wochen ohne Probleme.
Ich hatte das vor ca. 4 Wochen schonmal. Ich hab nix gefunden und den PC
komplett neu installiert.
Aber das kanns ja net sein das ich das schon wieder machen muß :(
Ich schreib so in die Ereignisanzeige:
EventLog.WriteEntry("myService", "irgendnen_Text",
EventLogEntryType.Information);

Ich hab alle aktuellen Patch's drauf die momentan verfügbar sind.

danke,
gruss,
Ralf


Ähnliche fragen