Kaputte OpenGL Ausgabe auf Matrox über DRI

02/08/2012 - 15:50 von Marcel Müller | Report spam
Hallo,

nachdem ich bei meiner Matrox-Karte die DRI-Ausgabe zum Laufen bekommen
habe, ist es zwar 10-mal so schnell, aber die Darstellung ist total kaputt.

siehe http://home.arcor.de/maazl/temp/Bil...to-Zaz.png
(Unten rechts die Ecke ist irgendwie beim Screenshot passiert, aber der
Rest ist real.)

Und genau so sieht es auch aus, wenn ich z.B. mit VLC den opengl
Videotreiber anspreche. Weiß auf weiß.

Das Logfile weiß nichts wirklich schlaues:
grep -P "EE|WW" /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or
'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0

Ich habe mal die experimentelle Option "AccelMethod" "EXA" angeworfen,
aber damit kommt der X-Server erst gar nicht hoch.

Was tun? Woran kann es liegen?


Marcel
 

Lesen sie die antworten

#1 Marcel Müller
04/08/2012 - 00:33 | Warnen spam
On 02.08.12 15.50, Marcel Müller wrote:
nachdem ich bei meiner Matrox-Karte die DRI-Ausgabe zum Laufen bekommen
habe, ist es zwar 10-mal so schnell, aber die Darstellung ist total kaputt.



Nach vielen Trial-And-Error Experimenten sieht es jetzt besser aus,
nachdem ich Option "AGPSize" "128" in die Device Section der xorg.conf
hinzugefügt habe. Offenbar ist ihn schlicht der Texturbuffer
ausgegangen, und der Rest war on error resume next. Bildfehler gibt es
allerdings immer noch.

Und genau so sieht es auch aus, wenn ich z.B. mit VLC den opengl
Videotreiber anspreche. Weiß auf weiß.



Die geht jetzt auch - allerdings bockt jetzt dafür der XV Treiber. Wenn
ich ihn mit mplayer oder VLC nutze semmelt der jeweilige Player ab.
Leider ist dem auch Wine zum Opfer gefallen. Jedenfalls die alten
DirectX 3 Fullscreen-Modi. Blöd.

Es bleibt also mirakulös.


Marcel

Ähnliche fragen