Forums Neueste Beiträge
 

KDE startet nicht mehr

19/07/2012 - 15:03 von Christian Althoff | Report spam
Hallo Zusammen,

ich habe hier ein kleines Problem

Nach dem leider erfolglosen Versuch auf meinem Schleppi (Lenovo TP520)
den NVIDIA Grafiktreiber 173.irgendwas von der Nvidia-Seite zu
installieren kann ich KDE (V 4.7.2) unter OpenSuse 12.1 nicht mehr
starten. Was ebenfalls nicht funktioniert ist die Multimedia-Oberflàche
"XBMC"
.
Ich vermute das irgendwas in den "3D"-Funktionen der Problem ist.

Was noch als GUI funktioniert ist IceWM.

Ich habe zwischenzeitlich ziemlich alle Grafiktreiber de- und neu
installiert:

den "Intel-legacy",

den "nouveau" und

den nvidia (wobei ich eigentlich nicht genau weiß ob der nvidia, der
nvidiaG1 oder der ..G2 der richtige ist - ich glaube der G1 ist der
richtige, er hat die Nvidia-Nummer 173.irgendwas) probiert hab ich alle 3

aus dem OpenSUSE-Quellen (also dir *RPM-Pakete, nicht selber kompiliert)



Die xorg.conf ist noch die originale die vorher auch lief:
Section "Device"
Identifier "vboxvideo"
Driver "vboxvideo"
EndSection

Section "Screen"
Identifier "vboxvideo"
Device "vboxvideo"
EndSection


Section "Device"
Identifier "vmware"
Driver "vmware"
EndSection

Section "Screen"
Identifier "vmware"
Device "vmware"
EndSection


Section "Device"
Identifier "cirrus"
Driver "cirrus"
EndSection
Section "Screen"
Identifier "cirrus"
Device "cirrus"
EndSection


Section "Device"
Identifier "fbdev"
Driver "fbdev"
EndSection
Section "Screen"
Identifier "fbdev"
Device "fbdev"
EndSection
-

Der Schleppi hat verscheidene BIOS-Einstellungen für die Grafikkarte:
die NVIDIA-Optimus, eine "Discret" (o. à) und eine 3. auf deren
Bezeichnungen ich gerade nicht komme, auch hier habe ich alle
Möglichkeiten getestet.

Ich habe nun leider keine Idee mehr, obwohl ich vermute das es wie so
oft nur eine Kleinigkeit ist die falsch làuft.

Gruß

Christian
 

Lesen sie die antworten

#1 Andreas Hartmann
20/07/2012 - 07:58 | Warnen spam
Christian Althoff schrieb:
Hallo Zusammen,

ich habe hier ein kleines Problem

Nach dem leider erfolglosen Versuch auf meinem Schleppi (Lenovo TP520)



Nach meinen Recherchen ist das ein Geràt mit einem Intel Core i5 2410M
(mit Intel HD Graphics 3000) in Verbindung mit einer zusàtzlichen nvidia
Graka (NVS 4200M).

den NVIDIA Grafiktreiber 173.irgendwas von der Nvidia-Seite zu
installieren kann ich KDE (V 4.7.2) unter OpenSuse 12.1 nicht mehr
starten. Was ebenfalls nicht funktioniert ist die Multimedia-Oberflàche
"XBMC"
.
Ich vermute das irgendwas in den "3D"-Funktionen der Problem ist.



Die Technik, zwei unterschiedliche Grafikkarten je nach
Leistungsanforderung zu nutzen, heißt Optimus. Die Unterstützung für
Linux ist bislang dem Vernehmen nach nicht sonderlich brauchbar.

Wenn überhaupt etwas hilft, dann Bumblebee. Pakete für openSUSE findest
Du hier:
http://software.opensuse.org/packag...=bumblebee

Offizielle Pakete gibt es da konsequenterweise keine (sind alles noch
"private" Pakete auf der Spielwiese), aber das dürfte ziemlich dem
Zustand des Projektes (http://bumblebee-project.org/) entsprechen. Ob da
was funktioniert oder nicht und wie, scheint ziemlicher Zufall zu sein
(Linus hat sich kürzlich ja auch dazu durch einen àußerst qualifizierten
Kommentar geàußert). Ein Support seitens nvidia ist nicht vorhanden
(Optimus sei eine Technologie speziell für Windows).


Mehr kann ich Dir leider nicht sagen, aber ich würde genau an dieser
Stelle ansetzen und versuchen, was zum Fliegen zu bekommen. Vielleicht
hast Du ja Glück!

Evtl. hast Du ja auch die Möglichkeit, im Bios eine Graka grundsàtzlich
zu deaktivieren.

Das ganze Theater hast Du eben, weil die Intel-Grafik aus meiner Sicht
weitgehend unbrauchbar ist und daher eine ordentliche Graka her muß,
welche Power liefert, wenn benötigt. Besser wàre, eine einzige,
ordentliche Graka zu verbauen und die so zu steuern, daß sie alle
Bereiche abdeckt (bei entsprechendem Stromverbrauch).

Von Intel natürlich trickreich, ihre Graka in den Prozessor zu stecken.
Wàre die da nicht drin, würden sie vermutlich keine einzige Graka
verkaufen ... .



Gruß,
Andreas

Ähnliche fragen