KDE4.0.4 One-Klick-Install (lang!)

26/05/2008 - 21:52 von Uwe Premer | Report spam
Habe jetzt auf die neu installierte OpenSUSE 10.3_64 (ohne die Pakete
kde3.9.3) versucht, KDE4 via One-Klick-Installation über kde.org zu
installieren.

Anfangs klappte das auch, aber einige Pakete wurden dann doch nicht
installiert, so dass KDE4 jetzt nicht startet.

Wenn ich nun ein weiteres Mal eine One-Klick-Install versuche, erhalte ich
folgende Abhàngigkeitsprobleme:

#### YaST2 conflicts list - generated 2008-05-26 21:39:32 ####

Fehlende Abhàngigkeiten von k3b
Es sind keine installierbaren Anbieter von kdebase3 verfügbar für
k3b-1.0.4-45.1.x86_64
k3b-1.0.4-45.1.x86_64 == kdebase3-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3 == 3.5.7-87 zur Verfügung, ist aber nicht installierbar.
Versuchen Sie das Objekt separat zu installieren, um weitere Details zu
erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
k3b-1.0.4-45.1.x86_64 hàngt von kdebase3 ab
k3b-1.0.4-45.1.x86_64 fehlt die Anforderung kdebase3
(null)
Konfliktlösung:
( ) k3b löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdeaddons3-kate
Es sind keine installierbaren Anbieter von libkateinterfaces.so.0(
(64bit) verfügbar für kdeaddons3-kate-3.5.9-10.8.x86_64
kdeaddons3-kate-3.5.9-10.8.x86_64 == kdebase3-3.5.7-87.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
libkateinterfaces.so.0()(64bit) zur Verfügung, ist aber nicht
installierbar. Versuchen Sie das Objekt separat zu installieren, um
weitere Details zu erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt libkateinterfaces.so.0()(64bit)
zur Verfügung, soll jedoch planmàßig deinstalliert werden.
kdeaddons3-kate-3.5.9-10.8.x86_64 hàngt von kdebase3 ab
kdeaddons3-kate-3.5.9-10.8.x86_64 fehlt die Anforderung
libkateinterfaces.so.0()(64bit)
(null)
Konfliktlösung:
( ) kdeaddons3-kate löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3
Es sind keine installierbaren Anbieter von kdebase3-ksysguardd verfügbar
für kdebase3-3.5.9-91.3.x86_64
kdebase3-3.5.9-91.3.x86_64 == kdebase3-ksysguardd-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3-ksysguardd == 3.5.7-87 zur Verfügung, ist aber nicht
installierbar. Versuchen Sie das Objekt separat zu installieren, um
weitere Details zu erhalten.
kdebase3-ksysguardd-3.5.9-91.3.x86_64 stellt kdebase3-ksysguardd =3.5.9-91.3 zur Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-3.5.9-91.3.x86_64 hàngt von kdebase3-ksysguardd ab
kdebase3-3.5.9-91.3.x86_64 fehlt die Anforderung kdebase3-ksysguardd
(null)
Konfliktlösung:
( ) kdebase3 löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3-beagle
Es sind keine installierbaren Anbieter von
libkickoffsearch_interfaces.so.0()(64bit) verfügbar für
kdebase3-beagle-3.5.9-91.3.x86_64
kdebase3-beagle-3.5.9-91.3.x86_64 == kdebase3-3.5.7-87.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
libkickoffsearch_interfaces.so.0()(64bit) zur Verfügung, ist aber nicht
installierbar. Versuchen Sie das Objekt separat zu installieren, um
weitere Details zu erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt libkickoffsearch_interfaces.so.0(
(64bit) zur Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-beagle-3.5.9-91.3.x86_64 hàngt von kdebase3 ab
kdebase3-beagle-3.5.9-91.3.x86_64 fehlt die Anforderung
libkickoffsearch_interfaces.so.0()(64bit)
(null)
Konfliktlösung:
( ) kdebase3-beagle löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3-devel
Es sind keine installierbaren Anbieter von kdebase3 == 3.5.9 verfügbar
für kdebase3-devel-3.5.9-91.3.x86_64
kdebase3-devel-3.5.9-91.3.x86_64 == kdebase3-3.5.9-91.3.x86_64[SUSE_KDE3] stellt kdebase3 == 3.5.9-91.3
zur Verfügung, ist aber nicht installierbar. Versuchen Sie das Objekt
separat zu installieren, um weitere Details zu erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-devel-3.5.9-91.3.x86_64 hàngt von kdebase3 ab
kdebase3-devel-3.5.9-91.3.x86_64 fehlt die Anforderung kdebase3 =3.5.9
(null)
Konfliktlösung:
( ) kdebase3-devel löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3-extra
Es sind keine installierbaren Anbieter von libkhotkeys_shared.so.1(
(64bit) verfügbar für kdebase3-extra-3.5.9-91.3.x86_64
kdebase3-extra-3.5.9-91.3.x86_64 == kdebase3-3.5.7-87.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
libkhotkeys_shared.so.1()(64bit) zur Verfügung, ist aber nicht
installierbar. Versuchen Sie das Objekt separat zu installieren, um
weitere Details zu erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt libkhotkeys_shared.so.1()(64bit)
zur Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-extra-3.5.9-91.3.x86_64 hàngt von kdebase3 ab
kdebase3-extra-3.5.9-91.3.x86_64 fehlt die Anforderung
libkhotkeys_shared.so.1()(64bit)
(null)
Konfliktlösung:
( ) kdebase3-extra löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3-nsplugin
Es sind keine installierbaren Anbieter von kdebase3 verfügbar für
kdebase3-nsplugin-3.5.9-91.3.i586
kdebase3-nsplugin-3.5.9-91.3.i586 == kdebase3-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3 == 3.5.7-87 zur Verfügung, ist aber nicht installierbar.
Versuchen Sie das Objekt separat zu installieren, um weitere Details zu
erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-nsplugin-3.5.9-91.3.i586 hàngt von kdebase3 ab
kdebase3-nsplugin-3.5.9-91.3.i586 fehlt die Anforderung kdebase3
(null)
Konfliktlösung:
( ) kdebase3-nsplugin löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3-session
Es sind keine installierbaren Anbieter von kdebase3 verfügbar für
kdebase3-session-3.5.9-91.3.x86_64
kdebase3-session-3.5.9-91.3.x86_64 == kdebase3-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3 == 3.5.7-87 zur Verfügung, ist aber nicht installierbar.
Versuchen Sie das Objekt separat zu installieren, um weitere Details zu
erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-session-3.5.9-91.3.x86_64 hàngt von kdebase3 ab
kdebase3-session-3.5.9-91.3.x86_64 fehlt die Anforderung kdebase3
(null)
Konfliktlösung:
( ) kdebase3-session löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdebase3-SuSE
Es sind keine installierbaren Anbieter von kdebase3 verfügbar für
kdebase3-SuSE-10.3-152.x86_64
kdebase3-SuSE-10.3-152.x86_64 == kdebase3-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3 == 3.5.7-87 zur Verfügung, ist aber nicht installierbar.
Versuchen Sie das Objekt separat zu installieren, um weitere Details zu
erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
kdebase3-SuSE-10.3-152.x86_64 hàngt von kdebase3 ab
kdebase3-SuSE-10.3-152.x86_64 fehlt die Anforderung kdebase3
(null)
Konfliktlösung:
( ) kdebase3-SuSE löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von kdepim3
Es sind keine installierbaren Anbieter von kdebase3 >= 3.5.9 verfügbar
für kdepim3-3.5.9-41.5.x86_64
kdepim3-3.5.9-41.5.x86_64 == kdebase3-3.5.9-91.3.x86_64[SUSE_KDE3] stellt kdebase3 == 3.5.9-91.3
zur Verfügung, ist aber nicht installierbar. Versuchen Sie das Objekt
separat zu installieren, um weitere Details zu erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
kdepim3-3.5.9-41.5.x86_64 hàngt von kdebase3 ab
kdepim3-3.5.9-41.5.x86_64 fehlt die Anforderung kdebase3 >= 3.5.9
(null)
Konfliktlösung:
( ) kdepim3 löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von pattern:kde_basis
Es sind keine installierbaren Anbieter von kdebase3 verfügbar für
pattern:kde_basis-10.3-159.x86_64
pattern:kde_basis-10.3-159.x86_64 == kdebase3-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3 == 3.5.7-87 zur Verfügung, ist aber nicht installierbar.
Versuchen Sie das Objekt separat zu installieren, um weitere Details zu
erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
pattern:kde_basis-10.3-159.x86_64 hàngt von kdebase3 ab
pattern:kde_basis-10.3-159.x86_64 fehlt die Anforderung kdebase3
(null)
Konfliktlösung:
( ) kde_basis löschen
( ) Anforderung nur hier ignorieren
Fehlende Abhàngigkeiten von python-kde3
Es sind keine installierbaren Anbieter von kdebase3 >= 3.5.7 verfügbar
für python-kde3-3.16.0-28.x86_64
python-kde3-3.16.0-28.x86_64 == kde4-konsole-4.0.4-12.1.x86_64 wird benötigt von
python-kde3-3.16.0-28.x86_64 (libkonsolepart.so()(64bit))
kdebase3-3.5.7-87.i58
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt
kdebase3 == 3.5.7-87 zur Verfügung, ist aber nicht installierbar.
Versuchen Sie das Objekt separat zu installieren, um weitere Details zu
erhalten.
kdebase3-3.5.9-91.3.x86_64 stellt kdebase3 == 3.5.9-91.3 zur
Verfügung, soll jedoch planmàßig deinstalliert werden.
python-kde3-3.16.0-28.x86_64 hàngt von kdebase3 ab
python-kde3-3.16.0-28.x86_64 fehlt die Anforderung kdebase3 >= 3.5.7
(null)
Konfliktlösung:
( ) python-kde3 löschen
( ) Anforderung nur hier ignorieren
kde4-knewsticker kann aufgrund fehlender Abhàngigkeiten nicht installiert
werden
Es sind keine installierbaren Anbieter von libakonadi4 >= 4.0.80
verfügbar für kde4-knewsticker-4.0.4-7.21.x86_64[20080526-193952]
kde4-knewsticker-4.0.4-7.21.x86_64[20080526-193952] == kde4-knewsticker-4.0.4-7.21.x86_64[20080526-193952] wird durch ein
andere Programm installiert.
libkdepimlibs4-4.0.72-6.1.x86_64 wird benötigt von
kde4-knewsticker-4.0.4-7.21.x86_64[20080526-193952] (libsyndication.so.4(
(64bit))
akonadi-runtime-0.81.0-2.1.x86_64[20080526-193952] wird benötigt von
kde4-knewsticker-4.0.4-7.21.x86_64[20080526-193952] (akonadi-runtime >0.80)
(null)
Konfliktlösung:
( ) kde4-knewsticker nicht installieren
( ) Anforderung nur hier ignorieren
kde4-kopete kann aufgrund fehlender Abhàngigkeiten nicht installiert werden
Es sind keine installierbaren Anbieter von libakonadi4 >= 4.0.80
verfügbar für kde4-kopete-4.0.4-7.21.x86_64[20080526-193952]
kde4-kopete-4.0.4-7.21.x86_64[20080526-193952] == kde4-kopete-4.0.4-7.21.x86_64[20080526-193952] wird durch ein andere
Programm installiert.
libxslt-1.1.20-41.x86_64 wird benötigt von
kde4-kopete-4.0.4-7.21.x86_64[20080526-193952] (libxslt.so.1()(64bit))
libopenssl0_9_8-0.9.8e-45.5.x86_64 wird benötigt von
kde4-kopete-4.0.4-7.21.x86_64[20080526-193952] (libssl.so.0.9.8()(64bit))
Weitere 6...
Konfliktlösung:
( ) kde4-kopete nicht installieren
( ) Anforderung nur hier ignorieren
kdebase3-ksysguardd steht in Konflikt mit anderen auflösbaren Objekten
kdebase3-ksysguardd-3.5.9-91.3.x86_64 steht in Konflikt mit:
kdebase4-workspace-ksysguardd-4.0.4-49.1.x86_64[20080526-193952]
kdebase4-workspace-ksysguardd-4.0.4-49.1.x86_64[20080526-193952] == kdebase4-workspace-ksysguardd-4.0.4-49.1.x86_64[20080526-193952]
wird empfohlen von kdebase4-workspace-4.0.4-49.1.x86_64[20080526-193952]
(kdebase4-workspace-ksysguardd)
(null)
Konfliktlösung:
( ) kdebase3-ksysguardd löschen
( ) kdebase4-workspace-ksysguardd nicht installieren
( ) Diesen Konflikt von kdebase3-ksysguardd ignorieren
pattern:kde_basis kann aufgrund fehlender Abhàngigkeiten nicht installiert
werden
Es sind keine installierbaren Anbieter von kdebase3 verfügbar für
pattern:kde_basis-10.3-159.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
pattern:kde_basis-10.3-159.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] == pattern:kde_basis-10.3-159.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] wird
benötigt von pattern:kde_imaging-10.3-159.x86_64 (kde_basis)
pattern:base-10.3-159.x86_64 wird benötigt von
pattern:kde_basis-10.3-159.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
(basesystem)
kdelibs3-3.5.9-62.2.x86_64 wird benötigt von
pattern:kde_basis-10.3-159.x86_6
[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]
(kdelibs3 == 3.5.9-62.2)
Weitere 28...
Konfliktlösung:
( ) kde_basis nicht installieren
( ) Anforderung nur hier ignorieren
Wenn nur Abhàngigkeiten der besten Architektur verwendet werden, wird keine
eindeutige Lösung gefunden.
Bei diesem Lösungsversuch wurden nur Abhàngigkeiten in der besten
Architektur berücksichtigt.
Alle auflösbaren Objekte zu berücksichtigen braucht viel Zeit, kann aber
zu einem besseren Ergebnis führen.
Konfliktlösung:
( ) Versuche eine Lösung zu finden, die ALLE Möglichkeiten
berücksichtigt.

#### YaST2 conflicts list END ###


Habe aber alle repos aktiviert als auch das Standard-Repo bei der
Installation aktiviert wie unter <http://en.opensuse.org/KDE/KDE4>
beschrieben:
|If you get a message that dependencies cannot be resolved, enter
|the "Advanced Mode" of the one-click handler and enable the "standard"
|online repository of your distribution.

Es sind übrigens nahezu alle zum Start von KDE4 erforderlichen Pakete schon
installiert, lediglich die folgenden Pakete fehlen:
kde4-kwin,
kde4-workspace
Will ich nur diese beiden Pakete nachinstallieren über YAST, kommen auch
dort genau die gleichen Abhàngigkeitsprobleme wie oben.

Wie kann ich jetzt doch noch KDE 4.0.4 fertig installieren?

Uwe
 

Lesen sie die antworten

#1 Maik Qualmann
26/05/2008 - 22:09 | Warnen spam
Uwe Premer wrote:

Wie kann ich jetzt doch noch KDE 4.0.4 fertig installieren?



Einfach mal 1-2 Tage warten, die Pakete werden fast tàglich erneuert. Mein
Updateversuch von heute hat den gleichen Fehler (das Problem gab es vor ein
paar Tagen schon mal).

Maik Qualmann

Ähnliche fragen