kdevelop in stretch funktioniert nicht richtig

01/12/2015 - 22:40 von Vladislav Vorobiev | Report spam
Hi,

benutzt hier jemand kdevelop?

Ich habe die Version 4:4.7.1-2 (stretch)

und die macht Probleme bei der Indexierung, also kurz nach dem start kracht
es.

...
...
Python::ExpressionVisitor::visitList: [ !!! ] did not get a typetrack
container object when expecting one! Fix code / setup.
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitList: [ !!! ] did not get a typetrack
container object when expecting one! Fix code / setup.
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitList: [ !!! ] did not get a typetrack
container object when expecting one! Fix code / setup.
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitList: [ !!! ] did not get a typetrack
container object when expecting one! Fix code / setup.
=> PARSING => parsing file KUrl("file:///usr/lib/python3.4/abc.py") ;
has priority -10003
=> DUCHAIN => building duchain for
"/usr/lib/python3.4/collections/__init__.py"
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitList: [ !!! ] did not get a typetrack
container object when expecting one! Fix code / setup.
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
=> AST => building abstract syntax tree for
"/usr/lib/python3.4/abc.py"
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitList: [ !!! ] did not get a typetrack
container object when expecting one! Fix code / setup.
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
=> DUCHAIN => rebuilding duchain for "/usr/lib/python3.4/abc.py"
(was built before)
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
kdevelop(22173)/kdevelop (python support)
Python::ExpressionVisitor::visitTuple: tuple type object is not available
QSocketNotifier: Invalid socket 7 and type 'Read', disabling...
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
QSocketNotifier: Invalid socket 34 and type 'Read', disabling...
QSocketNotifier: Invalid socket 36 and type 'Exception', disabling...
QSocketNotifier: Invalid socket 22 and type 'Read', disabling...
QSocketNotifier: Invalid socket 18 and type 'Read', disabling...
kdevelop: Fatal IO error: client killed
TopDUContextData::m_usedDeclarationIds There were items left on destruction:
11
DUContextData::m_uses There were items left on destruction: 605
FunctionDeclarationData::m_decorators There were items left on destruction: 62
ClassDeclarationData::baseClasses There were items left on destruction: 23
DUContextData::m_importers There were items left on destruction: 338
DUContextData::m_importedContexts There were items left on destruction: 314
FunctionTypeData::m_arguments There were items left on destruction: 4
FunctionDeclarationData::m_defaultParameters There were items left on
destruction: 308
DUContextData::m_childContexts There were items left on destruction: 687
DUContextData::m_localDeclarations There were items left on destruction: 687
TopDUContextData::m_problems There were items left on destruction: 12
Unable to start Dr. Konqi
Not forwarding the crash to Apport.

Gruss
Vlad
 

Lesen sie die antworten

#1 Gerhard Wolfstieg
01/12/2015 - 23:30 | Warnen spam
Hallo Vladislav, hallo zusammen!

Am Wed, 02 Dec 2015 00:35:36 +0300
schrieb Vladislav Vorobiev :

Hi,

benutzt hier jemand kdevelop?

Ich habe die Version 4:4.7.1-2 (stretch)



Die habe ich auch schon installiert und jetzt gerade eben das erste mal
probiert (Projekt erstellt, beendet, kdevelop wieder gestartet). Tut
soweit, …

und die macht Probleme bei der Indexierung, also kurz nach dem start kracht
es.



… habe aber möglicherweise kein indexing aktiviert – fahre auch nicht
KDE sondern Window Maker. Vielleicht hilft daß, den Fehler einzugrenzen.

<fuehrt_eigentlich_zu_weit>
Mein Projekt wird allerdings nicht erstellt; weiß auf die Schnelle auch
nicht welches Paket eventuell fehlt:

CMake Error at /usr/share/cmake-3.3/Modules/FindQt4.cmake:634 (message):
Could NOT find QtCore. Check
/D/Projekte/kdevelop_test/Test/build/CMakeFiles/CMakeError.log for
more
details.

CMakeError.log gibt es nicht.
</fuehrt_eigentlich_zu_weit>

Grüße, Gerhard

Ähnliche fragen