Kein glx über ssh

08/08/2016 - 20:20 von Kai-Martin Knaak | Report spam
Moin.

In meinem kleinen Linux-Pool hier hakelt es ein wenig, was Anwendungen mit
openGL angeht. Lokal auf dem Monitor des jeweiligen Rechners laufen sie
problemlos. Aber über ssh ernte ich Fehlermeldungen. Einfache X-Anwendungen
wie etwa das gute, alte oclock werden erfolgreich über ssh gestartet. Aber
alles, was openGL benutzt, scheitert mit Fehlermeldungen. Die gleichen
Meldungen bekomme ich auch mit glxinfo:

/--
$ export LIBGL_DEBUG=verbose
$ glxinfo
name of display: localhost:10.0
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL: Can't open configuration file /home/kmk/.drirc: No such file or directory.
libGL: Can't open configuration file /home/kmk/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: GLXBadContext
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 6 (X_GLXIsDirect)
Serial number of failed request: 48
Current serial number in output stream: 47
$
\-

Den Treiber
/usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
habe ich nicht. Laut apt-file gibt es den ganzen Order dri/tls in keinem
Debian-Paket..

Aber am anderen Pfad existiert ein Treiber:
$ ll /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
-rw-r--r-- 8 root root 9.3M May 11 13:11 /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so

Und nu?
Sieht so aus, als würde eine wesentliche Konfiguration fehlen. Nur welche?
(Alle beteiligten Rechner laufen mit monatlich aktuell gehaltenem testing/stretch.)


<)kaimartin(>
Kai-Martin Knaak tel: +49-511-762-2895
Universitàt Hannover, Inst. für Quantenoptik fax: +49-511-762-2211
Welfengarten 1, 30167 Hannover http://www.iqo.uni-hannover.de
GPG key: http://pgp.mit.edu:11371/pks/lookup?search=Knaak+kmk&op=get
 

Lesen sie die antworten

#1 Stefan Baur
10/08/2016 - 16:50 | Warnen spam
Am 08.08.2016 um 20:15 schrieb Kai-Martin Knaak:
Moin.

In meinem kleinen Linux-Pool hier hakelt es ein wenig, was Anwendungen mit
openGL angeht. Lokal auf dem Monitor des jeweiligen Rechners laufen sie
problemlos. Aber über ssh ernte ich Fehlermeldungen. Einfache X-Anwendungen
wie etwa das gute, alte oclock werden erfolgreich über ssh gestartet. Aber
alles, was openGL benutzt, scheitert mit Fehlermeldungen. Die gleichen
Meldungen bekomme ich auch mit glxinfo:



Ich rate ja selten dazu, bei bestehenden Problemsituationen noch etwas
Komplexitàt hinzuzufügen, aber hast Du es mal mit X2Go statt ssh -X
versucht?

Ich habe mal eben bei mir spaßeshalber glxgears über X2Go gestartet und
das lief.

Disclaimer: Ich bin der Community Manager des X2Go-Projekts. ;-)

Linkliste zum Einstieg:
http://wiki.x2go.org/doku.php/doc:newtox2go
http://wiki.x2go.org/doku.php/doc:installation:x2goserver#debian
http://wiki.x2go.org/doku.php/doc:installation:x2goclient#ubuntu_debian
http://lists.x2go.org/listinfo/x2go-user

Gruß
Stefan

Ähnliche fragen