Forums Neueste Beiträge
 

Kein Remote Debugging nach Security Update von VS2005

22/10/2009 - 14:56 von Diana | Report spam
So im Juli/August gab es für VS2005 ein Security Update wobei auch die MFC
upgedated wurde.

Vorher konnte man mittels msvsmon und VS2005 per LAN Verbindung ein Remote
Debugging durchführen. Nach dem Update, kann man im msvsmon Monitor Fenster
beim Attach to Process... die Verbindung vom VS2005 zum msvsmon beim Anmelden
sehen (Connected) und normalerweise wird dann das VS2005 über den Erfolg der
Verbindung informiert und die Prozessliste vom Client geliefert aber genau
diese Rückinformation kommt nicht durch (Target wurde nicht veràndert und auf
der Client Seite mit VS2005 wurden nur die Sicherheitsupdates eingespielt).

Das ist bei uns kein Einzelfall sondern auf allen Arbeitsrechnern so.
Auf meinem PC habe ich IE8 dann deinstalliert (auf den anderen PCs mit
gleichem Problem ist nur IE7 drauf). Beim zurückbauen wird dann der vorherige
IE aktiviert der bei mir IE7 war. Dabei wird ein ganzer Haufen an Komponenten
zurück gebaut und man erhàlt eine explizite Warnung, welche anderen Programme
davon betroffen sein könnten. Hab mich davon jedoch nicht abhalten lassen und
tapfer deinstalliert. Bin mir aber sicher, dass es nicht direkt mit dem IE
etwas zutun haben kann. Jetzt ist auf allen PCs IE7 aktiviert aber nur bei
mir, làuft das Remote Debugging wie vor dem Security Update, nach dem ich wie
geschrieben IE8 deinstalliert habe.

Ist das Problem bekannt und gibt es eine Lösung dafür?
 

Lesen sie die antworten

#1 Diana
23/10/2009 - 15:43 | Warnen spam
Beim Attach versuch von VS2005 zu msvsmon bekomme ich die Fehlermeldung "The
Remote Debugging Monitor on the remote computer does not have permission to
connect to this computer"

Der Client (VS2005) ist an einer Domaine angemeldet, das Target (msvsmon)
befindet sich einer Workgroup.

Auf dem Target ist ein lokaler User mit gleichem Namen und Passwort
eingerichten, wie der Account, unter dem VS2005 làuft. Was dabei wohl geht
ist, dass ein Domainen Account auf ein lokales abgebildet werden kann. Darum
nimmt msvsmon den Verbindungswunsch vom VS2005 an, aber umgekehrt geht es
nicht. Ein lokales Account ist nicht auf ein Domainen Account abbildbar und
daher fehlt die Permission.

Nur wie biegt man das hin? Hab jetzt auf dem Client zusàtzlich auch noch
einen lokalen Account mit gleichem Usernamen und Passwort eingerichtet, dass
hat aber nicht geholfen.

Wenn man msvsmon mit runas und dem gleichen lokalen Account auf dem Target
startet, dann klappt auch die Rückverbindung. Wenn jetzt die Applikation auch
mit runas und dem Account gestartet wird, müsste der Zugriff (bzw. das Remote
Debuggen) gehen. Leider habe ich aber nur erschwert die Möglichkeit die
Applikation unter einem bestimmten Account zu starten, so dass ich gerne
darauf verzichten würde.

Hat jemand eine Idee, wie man das Rund hinbekommen kann?

Ähnliche fragen