kein resume nach hibernate

17/09/2016 - 20:57 von Ulli Horlacher | Report spam
Ich hab hier 2 identische Thinkpad 460s mit Ubuntu 16.04, bei einem
funktioniert hibernate/resume, beim anderen nicht: hibernate geht noch,
aber nach Wiedereinschalten macht der kein resume, sondern einen
Initial-boot.

Ich rufe direkt als root auf: /usr/sbin/pm-hibernate

EIGENTLICH sollten beide gleich konfiguriert sein, aber ich hab wohl was
verbockt. Nur was und wie findet man das?


Im kern.log findet sich nach reboot:

Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0x00000000-0x00000fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0x0009d000-0x0009ffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0x000a0000-0x000dffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0x000e0000-0x000fffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xb9bbf000-0xcca8ffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xcca90000-0xcca90fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xcca91000-0xd7f7dfff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xd7f7e000-0xd7fcdfff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xd7fce000-0xd7ffdfff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xd7ffe000-0xd80fffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xd8100000-0xd85fffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xd8600000-0xdc7fffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xdc800000-0xf7ffffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xf8000000-0xfbffffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfc000000-0xfcffffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfd000000-0xfe7fffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfe800000-0xfebfffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfec00000-0xfec00fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfec01000-0xfecfffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfed00000-0xfed00fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfed01000-0xfed0ffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfed10000-0xfed19fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfed1a000-0xfed83fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfed84000-0xfed84fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfed85000-0xfedfffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfee00000-0xfee00fff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xfee01000-0xff7fffff]
Sep 17 20:22:56 wupp kernel: [ 0.000000] PM: Registered nosave memory: [mem 0xff800000-0xffffffff]
Sep 17 20:22:56 wupp kernel: [ 0.194756] PM: Registering ACPI NVS region [mem 0xcca90000-0xcca90fff] (4096 bytes)
Sep 17 20:22:56 wupp kernel: [ 0.194767] PM: Registering ACPI NVS region [mem 0xd7f7e000-0xd7fcdfff] (327680 bytes)
Sep 17 20:22:56 wupp kernel: [ 1.841014] PM: Hibernation image not present or could not be loaded.

Ullrich Horlacher Server und Virtualisierung
Rechenzentrum TIK
Universitaet Stuttgart E-Mail: horlacher@tik.uni-stuttgart.de
Allmandring 30a Tel: ++49-711-68565868
70569 Stuttgart (Germany) WWW: http://www.tik.uni-stuttgart.de/
REF:<20160917183907.GA8296@rus.uni-stuttgart.de>
 

Lesen sie die antworten

#1 Ulli Horlacher
17/09/2016 - 21:19 | Warnen spam
Ulli Horlacher wrote:
Ich hab hier 2 identische Thinkpad 460s mit Ubuntu 16.04, bei einem
funktioniert hibernate/resume, beim anderen nicht: hibernate geht noch,
aber nach Wiedereinschalten macht der kein resume, sondern einen
Initial-boot.



Habs hingekriegt:

Auf dem Thinkpad, wo das resume nicht funktioniert hatte, tut es nun
nachdem ich in /etc/default/grub das swap-device explizit angegeben habe
mit:

GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3"

(und noch update-grub)

Ich versteh nur nicht, warum das bei dem anderen Thinkpad nicht notwendig
ist. Beide haben die identische Partitionierung.


Ullrich Horlacher Server und Virtualisierung
Rechenzentrum TIK
Universitaet Stuttgart E-Mail:
Allmandring 30a Tel: ++49-711-68565868
70569 Stuttgart (Germany) WWW: http://www.tik.uni-stuttgart.de/

Ähnliche fragen