Kein Zugang zum Linux mehr

02/02/2009 - 21:12 von Wolfgang Koenig | Report spam
Hallo!

Ich hab ein Suse Linux 11 wie folgt ausser Betrieb gesetzt:

Ich wollte mit Yast ein Ethernet-Interface auf statische IP setzen, aber
offenbar irgendwo ein Hakerl übersehen. Der Erfolg ist, daß beim Restart
vom Linux dieses Interface als passiv (oder nicht aktiv) gemeldet wird und
ich daher von da aus nicht mehr an den Rechner komme.

Unglücklicherweise komm ich an der Konsole auch nicht rein, der Rechner
startet seine Dienste und bei inetd (oder einen Dienst danach) bleibt er
ohne den Login prompt.

Die virtuellen Konsolen sind auch (nicht) soweit, von denen kann ich auch
nicht rein.

Bei der zweiten Bootoption werden weitestgehend dieselben Dienste gestartet
und hier passiert das gleiche wie beim Standard-Boot.

Wenn man von einer Live CD bootet, kann man ja sicher die
Konfigurationsdateien editieren - aber welche sind für eth0 und eth1
zustàndig? Oder kann man mit Yast auch die gemountete Platte "bearbeiten"?

Am Einfachsten wàre es aber, wenn ich den Bootvorgang unterbrechen könnte
(Strg. C geht leider nicht) und danach mit Yast meinen Fehler wieder
korrigieren könnte - aber wie unterbricht man?

Ich hoffe auf einen guten Tipp - und bedanke mich auch gleich im voraus!

Wolfgang
 

Lesen sie die antworten

#1 Markus Kossmann
02/02/2009 - 21:29 | Warnen spam
Wolfgang Koenig wrote:

Hallo!

Ich hab ein Suse Linux 11 wie folgt ausser Betrieb gesetzt:

Ich wollte mit Yast ein Ethernet-Interface auf statische IP setzen, aber
offenbar irgendwo ein Hakerl übersehen. Der Erfolg ist, daß beim Restart
vom Linux dieses Interface als passiv (oder nicht aktiv) gemeldet wird und
ich daher von da aus nicht mehr an den Rechner komme.

Unglücklicherweise komm ich an der Konsole auch nicht rein, der Rechner
startet seine Dienste und bei inetd (oder einen Dienst danach) bleibt er
ohne den Login prompt.

Die virtuellen Konsolen sind auch (nicht) soweit, von denen kann ich auch
nicht rein.

Bei der zweiten Bootoption werden weitestgehend dieselben Dienste
gestartet und hier passiert das gleiche wie beim Standard-Boot.

Wenn man von einer Live CD bootet, kann man ja sicher die
Konfigurationsdateien editieren - aber welche sind für eth0 und eth1
zustàndig? Oder kann man mit Yast auch die gemountete Platte "bearbeiten"?


Schau mal unter /etc/sysconfig/network.


Am Einfachsten wàre es aber, wenn ich den Bootvorgang unterbrechen könnte
(Strg. C geht leider nicht) und danach mit Yast meinen Fehler wieder
korrigieren könnte - aber wie unterbricht man?


Hast du schon versucht im Single-User Mode zu starten ? Imdem Du als
runlevel 1 am Bootprompt angibst.

Ähnliche fragen