keine Null bei Formel mit leerem Feld

16/04/2009 - 11:10 von Captain Hook | Report spam
Hallo,
ich verzweifel gleich.
Ich habe eine Formel erstellt, bei der zwei Felder verglichen werden.

d.h.

Wenn A1>A2 dann lautet das Ergebnis 2
Wenn A1<A2 dann 0
Wenn A1¢ dann 1

Funktioniert wunderbar. NUR, wenn in den beiden Feldern keine Zahl eingeben
ist erscheint 1 Weil die Felder ja gleich sind.

Bitte um Hilfe.
Ich weiß nicht mehr weiter.

Danke
Markus
 

Lesen sie die antworten

#1 Wolfgang Habernoll
16/04/2009 - 12:23 | Warnen spam
Hallo Captain


"Captain Hook" <Captain schrieb im Newsbeitrag
news:
Hallo,
ich verzweifel gleich.
Ich habe eine Formel erstellt, bei der zwei Felder verglichen werden.

d.h.

Wenn A1>A2 dann lautet das Ergebnis 2
Wenn A1<A2 dann 0
Wenn A1¢ dann 1

Funktioniert wunderbar. NUR, wenn in den beiden Feldern keine Zahl eingeben
ist erscheint 1 Weil die Felder ja gleich sind.



das ist eigentlich auch logisch richtig, selbst wenn du A1=x A2=y nimmst wàre A2
größer. Leider zeigst du uns deine Formel nicht, aber ich denke du möchtest nur Zahlen
vergleichen? dann versuche es mal damit.

=WENN(UND(ISTZAHL(A1);ISTZAHL(A2));WENN(A1>A2;2;WENN(A1<A2;0;1));"")

mfG
Wolfgang Habernoll

[ Win XP Home SP-2 , XL2002 ]

Ähnliche fragen