Keine Verbindung via SMB mit Win7

17/11/2010 - 23:44 von Markus Enax | Report spam
Moin,

ich habe früher (vor einigen Monaten) in meinem LAN zuhause zwischen meinem
Linux-Laptop und einem Win7-Rechner problemlos via SMB-Protokoll Daten
austauschen können. Mittlerweile (also seit einiger Zeit, genauen Zeitpunkt
habe ich leider nicht mehr parat) klappt dieses allerdings nur noch sehr
sporadisch.

In 90% der Fàlle sagt mir der Konqueror nach dem Öffnen der 'Samba Shares'
und der entsprechenden Arbeitsgruppe nur:
"Keine Verbindung zum Rechner für smb://arbeitsgruppe/"

Über die Konsole bekomme ich mittels

smbclient -L rechnername

gefolgt vom Passwort des Freigabe-Users das folgende:


Domain=[rechnername] OS=[Windows 7 Professional 7600] Server=[Windows 7
Professional 6.1]

Sharename Type Comment
ADMIN$ Disk Remoteverwaltung
C$ Disk Standardfreigabe
D$ Disk Standardfreigabe
IPC$ IPC Remote-IPC
SMB Disk
Users Disk
Domain=[rechnername] OS=[Windows 7 Professional 7600] Server=[Windows 7
Professional 6.1]

Server Comment
-

Workgroup Master
-


Jemand eine Idee? Wie gesagt, es klappt manchmal, nur leider sehr selten.
Gebe notfalls noch mehr Senf dazu, ist aber jetzt schon spàt, sorry ...

MFG

Markus Enax
-
Debian/Sidux (i386) with KNode
Hannover/Germany (CET/CEST)
 

Lesen sie die antworten

#1 Joerg Honerla
18/11/2010 - 11:38 | Warnen spam
Markus Enax wrote:

Moin,

ich habe früher (vor einigen Monaten) in meinem LAN zuhause zwischen
meinem Linux-Laptop und einem Win7-Rechner problemlos via SMB-Protokoll
Daten austauschen können. Mittlerweile (also seit einiger Zeit, genauen
Zeitpunkt habe ich leider nicht mehr parat) klappt dieses allerdings nur
noch sehr sporadisch.

In 90% der Fàlle sagt mir der Konqueror nach dem Öffnen der 'Samba Shares'
und der entsprechenden Arbeitsgruppe nur:
"Keine Verbindung zum Rechner für smb://arbeitsgruppe/"

Über die Konsole bekomme ich mittels

smbclient -L rechnername

gefolgt vom Passwort des Freigabe-Users das folgende:


Domain=[rechnername] OS=[Windows 7 Professional 7600] Server=[Windows 7
Professional 6.1]

Sharename Type Comment
ADMIN$ Disk Remoteverwaltung
C$ Disk Standardfreigabe
D$ Disk Standardfreigabe
IPC$ IPC Remote-IPC
SMB Disk
Users Disk
Domain=[rechnername] OS=[Windows 7 Professional 7600] Server=[Windows 7
Professional 6.1]

Server Comment
-

Workgroup Master
-



Was hier auffàllt: Es ist kein Workgroup-Master gefunden worden. Damit kann
der Linux-Rechner auf keinen Rechner der Workgroup zugreifen. Verhindert auf
dem W7-Rechner vielleicht ein Firewall das?

Andere Möglichkeit. zulassen der der Linux-Rechner Workgroup-Master wird.

smb.conf: preferred master = Yes

Und dann Samba neu starten, eine Zeitlang warten und dann mal smbclient -L
rechnername starten.

Bei mir sieht es so aus:

Server Comment
-
xxxxxx Notebook
xxxxxx Peter
SERVER Institutsserver (Samba 3.2)
xxxxxxxxxxxxxxx Arbeitsplatzrechner

Workgroup Master
-
xxxxxxxx SERVER


Jörg



Jemand eine Idee? Wie gesagt, es klappt manchmal, nur leider sehr selten.
Gebe notfalls noch mehr Senf dazu, ist aber jetzt schon spàt, sorry ...

MFG

Ähnliche fragen