Keinen Rat bei Parameter übergabe...

03/10/2008 - 15:37 von Heiden Andre | Report spam
Hallo Gemeinde..

erst mal nee Frage: gibts für Spotlight Forum eigentlich nen Ersatzforum ??

Aber hier mein Porblem:

Ich rufe eine Function folgendermassen auf:

Call Prozente_berechnen(Date, var_uhrzeitstartprozente, var_date, var_time,
var_mitarbeiterID, stid)

Alle Variablen sind auch mit Inhalt gefüllt...

Nun die Function selber:

Public Function Prozente_berechnen(beginn_datum As Variant, _
beginn_uhrzeit As Variant, _
ende_datum As Variant, _
ende_uhrzeit As Variant, _
Mitarbeiterid As Variant, _
DatensatzID As Variant)

es kommt aber sofort eine Fehlermeldung " Fehler beim Kompilieren
Argumenttyp ByRef unvertràglich"

Dann habe ich mal im Direktfenster die Variablen anzeigen lassen, und alle
sind komischer weise leer, und im Aufruf sind sie aber vorhanden...

Ich habe auch mal alle Datetypen geàndert und getestet, keine Änderung..
Irgendwie steh ich im Moment auffem Schlauch..

Kann mir mal einer helfen..

Mit Dank im Voraus
Andre Heiden
 

Lesen sie die antworten

#1 Heiden Andre
03/10/2008 - 20:01 | Warnen spam
Falsche Newsgroup.. SORRRRYYYYY.. :)

Verschoben nach microsoft.public.de.access


Am Fri, 3 Oct 2008 15:37:57 +0200 schrieb Heiden Andre:

Hallo Gemeinde..

erst mal nee Frage: gibts für Spotlight Forum eigentlich nen Ersatzforum ??

Aber hier mein Porblem:

Ich rufe eine Function folgendermassen auf:

Call Prozente_berechnen(Date, var_uhrzeitstartprozente, var_date, var_time,
var_mitarbeiterID, stid)

Alle Variablen sind auch mit Inhalt gefüllt...

Nun die Function selber:



Public Function Prozente_berechnen(beginn_datum As Variant, _
beginn_uhrzeit As Variant, _
ende_datum As Variant, _
ende_uhrzeit As Variant, _
Mitarbeiterid As Variant, _
DatensatzID As Variant)

es kommt aber sofort eine Fehlermeldung " Fehler beim Kompilieren
Argumenttyp ByRef unvertràglich"

Dann habe ich mal im Direktfenster die Variablen anzeigen lassen, und alle
sind komischer weise leer, und im Aufruf sind sie aber vorhanden...

Ich habe auch mal alle Datetypen geàndert und getestet, keine Änderung..
Irgendwie steh ich im Moment auffem Schlauch..

Kann mir mal einer helfen..

Mit Dank im Voraus
Andre Heiden

Ähnliche fragen