Kernelkompilierung: seltsame Fehlermeldung

10/01/2011 - 22:20 von Thomas Ansorg | Report spam
Hallo
was will mir diese Fehlermeldung sagen?
***********************************************************************************************************************
make[1]: Leaving directory `/usr/src/linux-2.6.35.10'
test ! -e scripts/package/builddeb || mv -f scripts/package/builddeb
scripts/package/builddeb.kpkg-dist
test ! -e scripts/package/Makefile || test -f
scripts/package/Makefile.kpkg-dist || (mv -f scripts/package/Makefile
scripts/package/Makefile.kpkg-dist && (echo "# Dummy file "; echo
"help:") > scripts/package/Makefile)
COLUMNS0 dpkg -l 'gcc*' perl dpkg 'libc6*' binutils make dpkg-dev |\
awk '$1 ~ /[hi]i/ { printf("%s-%s", $2, $3) }'> debian/buildinfo
uname -a >> debian/buildinfo
echo using the compiler: >> debian/buildinfo
grep LINUX_COMPILER include/linux/compile.h | \
sed -e 's/.*LINUX_COMPILER "//' -e 's/"$//' >> debian/buildinfo
grep: include/linux/compile.h: Datei oder Verzeichnis nicht gefunden
echo applied kernel patches: >> debian/buildinfo
echo done > debian/stamp/build/kernel
/usr/bin/make -f ./debian/rules
debian/stamp/binary/pre-linux-image-2.6.35.10
make[1]: Entering directory `/usr/src/linux-2.6.35.10'
making target debian/stamp/install/linux-image-2.6.35.10 [new
prereqs: ]==This is kernel package version 11.015.
echo "The UTS Release version in include/linux/version.h"; echo "
\"\" "; echo "does not match current version:"; echo " \"2.6.35.10\"
"; echo "Please correct this."; exit 2
The UTS Release version in include/linux/version.h
""
does not match current version:
"2.6.35.10"
Please correct this.
make[1]: *** [debian/stamp/install/linux-image-2.6.35.10] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.35.10'
make: *** [kernel_image] Fehler 2
*****************************************************************************************************************************************

Die Datei /usr/src/linux/include/linux/version.h enthàlt:
#define LINUX_VERSION_CODE 132643
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

Was soll ich da korrigieren? Eine Datei include/linux/compile.h gibts
auch nicht, nur eine compiler.h

Jetziges System: Debian 2.6.26

Gruß
T.
Wer Rechtschreibfehler findet, darf sie behalten!
 

Lesen sie die antworten

#1 lano
13/01/2011 - 00:34 | Warnen spam
Thomas Ansorg schrieb:
Hallo
was will mir diese Fehlermeldung sagen?

This is kernel package version 11.015.
echo "The UTS Release version in include/linux/version.h"; echo "
\"\" "; echo "does not match current version:"; echo " \"2.6.35.10\"
"; echo "Please correct this."; exit 2



ein bug im paket "kernel-package" ?
http://bugs.debian.org/cgi-bin/bugr...i?bugV1569

Was soll ich da korrigieren? Eine Datei include/linux/compile.h gibts
auch nicht, nur eine compiler.h



Ich glaube die heißt jetzt anders die Datei...

-Sven-

Ähnliche fragen