Kieine Datenbankdiagramme in SQL Srv. 2005

04/04/2008 - 17:31 von Florian Lehner | Report spam
Hi NG,

Folgendes Problem:

Auf mehreren DB, die von SQL Server 2000 nach 2005 migriert wurden, können
keine Datenbankdiagramme angezeigt werden. Es muss die Unterstützung für
Datenbankdiagramme bei jeder DB separat installiert werden. So weit so gut.

Die Installation schlàgt allerdings stets fehl:

„Die Unterstützungsobjekte für Datenbankdiagramme können nicht installiert
werden, da diese Datenbank keinen gültigen Besitzer hat. Verwenden Sie zum
Fortsetzen zuerst die Seite 'Dateien' des Dialogfeldes
'Datenbankeigenschaften' oder die ALTER AUTHORIZATION-Anweisung, um für den
Datenbankbesitzer gültige Anmeldeinformationen festzulegen, und fügen Sie
anschließend die Unterstützungsobjekte für Datenbankdiagramme hinzu.“


Folgendes habe ich getan:

-Kompatibilitàtsmodus der DB auf Server 2005 (90) gesetzt (von 2000 (50))
-Datenbankbesitzer ist DOMAIN\MeinLogInName (wie zugeordnet)
-der og. Nutzer hat alle Rechte und ist als Serveradmin auf dem SQL Server
eingetragen

…bringt aber alles nichts, es kommt ewig der gleiche Fehler.

Hat irgendwer eine IdeeP
 

Lesen sie die antworten

#1 Elmar Boye
07/04/2008 - 09:53 | Warnen spam
Hallo Florian,

Florian Lehner schrieb:
Auf mehreren DB, die von SQL Server 2000 nach 2005 migriert wurden, können
keine Datenbankdiagramme angezeigt werden. Es muss die Unterstützung für
Datenbankdiagramme bei jeder DB separat installiert werden. So weit so gut.

Die Installation schlàgt allerdings stets fehl:

„Die Unterstützungsobjekte für Datenbankdiagramme können nicht installiert
werden, da diese Datenbank keinen gültigen Besitzer hat. Verwenden Sie zum
Fortsetzen zuerst die Seite 'Dateien' des Dialogfeldes
'Datenbankeigenschaften' oder die ALTER AUTHORIZATION-Anweisung, um für den
Datenbankbesitzer gültige Anmeldeinformationen festzulegen, und fügen Sie
anschließend die Unterstützungsobjekte für Datenbankdiagramme hinzu.“


Folgendes habe ich getan:

-Kompatibilitàtsmodus der DB auf Server 2005 (90) gesetzt (von 2000 (50))
-Datenbankbesitzer ist DOMAIN\MeinLogInName (wie zugeordnet)
-der og. Nutzer hat alle Rechte und ist als Serveradmin auf dem SQL Server
eingetragen

…bringt aber alles nichts, es kommt ewig der gleiche Fehler.



Eigentlich sollte es so funktionieren.
Verwende bitte mal als Alternative "sa" als Datenbankbesitzer,
um evtl. Fehler bei der Zuordnung auszuschließen.

Service Pack 2 sollte zudem immer installiert sein, da bei der RTM
noch einige Fehler bei den Diagrammen auftraten.

Gruß Elmar

Ähnliche fragen