Kombinationsfeld bringt Vorschläge nicht

10/11/2009 - 13:08 von Gerhard Meier | Report spam
Hallo zusammen


In einem Formular "Vereinsmitgliederverwaltung" verwende ich drei
Kombinationsfelder für die Datensatzsuche. Bei der Textsuche
reagieren die Kombinationsfelder überhaupt nicht. Damit meine ich, wenn ich
z.B. Bauer in das Kombifeld schreibe, dann bleiben die
das Vorschalgen reaktionslos, also immer auf A... stehen. Bei der Eingabe
von Zahlen klappt es jedoch problemlos.

Ich habe alles schon mit Formularen verglichen wo dies richtig klappt jedoch
kein Unterschied festgestellt. Wenn man nun in den Eigenschaften

die Datensatzherkunft löscht und neu erstellt funktioniert das Vorschlagen
tadellos. Datenbank schliessen neu öffnen und der gleiche Ärger beginnt von

neuem. Nervt, vor allem weil ich schon zweimal das Formular von Grund auf
neu erstellt habe. In der selben Datenbank sind zwei Formulare von diesem

Bug betroffen. Alle anderen Formulare haben kein Bug, da funktioniert alles
Bestens.

die Textsuche bringt auch das gewünschte Ergebnis.



Hat einer von Euch eine hilfreiche Idee?





Access 07 SP / SP2 / Vista



Anzahldatenstàze: 130



Besten Dank für jeden Tipp
 

Lesen sie die antworten

#1 Peter Doering
10/11/2009 - 16:47 | Warnen spam
Hallo,

Gerhard Meier wrote:

In einem Formular "Vereinsmitgliederverwaltung" verwende ich drei
Kombinationsfelder für die Datensatzsuche. Bei der Textsuche
reagieren die Kombinationsfelder überhaupt nicht. Damit meine ich, wenn ich
z.B. Bauer in das Kombifeld schreibe, dann bleiben die
das Vorschalgen reaktionslos, also immer auf A... stehen. Bei der Eingabe
von Zahlen klappt es jedoch problemlos.



Existiert denn ein Eintrag fuer Bauer, bzw. mit B beginnend?

Ich habe alles schon mit Formularen verglichen wo dies richtig klappt jedoch
kein Unterschied festgestellt. Wenn man nun in den Eigenschaften
die Datensatzherkunft löscht und neu erstellt funktioniert das Vorschlagen
tadellos. Datenbank schliessen neu öffnen und der gleiche Ärger beginnt von
neuem. Nervt, vor allem weil ich schon zweimal das Formular von Grund auf
neu erstellt habe. In der selben Datenbank sind zwei Formulare von diesem
Bug betroffen. Alle anderen Formulare haben kein Bug, da funktioniert alles
Bestens.



Wird die RowSource des Kombifeldes irgendwo per VBA gesetzt? Sind evtl.
Filter gesetzt? Zeig vorsichtshalber mal auch den SQL-String der RowSource.

Gruss - Peter

Mitglied im http://www.dbdev.org
FAQ: http://www.donkarl.com

Ähnliche fragen