Kombinatorik Problem

02/09/2008 - 17:39 von Simarion | Report spam
Hallo zusammen,

ich hàtte eine Frage, denn hier hören meine Excel-Kenntnisse auf:

Ich habe eine List mit unterschiedlichen Wörtern. Diese Wörter möchte
ich nun mit einander kombinieren, wobei keins doppelt vorkommen soll.
Maximal soll das Ergebnis aus min. 2 max. 6 Wörtern bestehen.

Ein Beispiel

Wörter: Haus, Baum, Gras, Blatt, Hund, Katze, Stamm, Braun

Kombinationen:
Haus, Baum
Baum, Haus
Haus, Baum, Gras, Blatt, Hund, Katze
Baum, Gras, Katze, Stamm, Braun, Haus

Für Hilfen wàre ich sehr dankbar. Vielleicht auch, wie ich die
Ausgangstabelle aufbauen sollte.

Cheers
Simarion
 

Lesen sie die antworten

#1 Peter Schleif
02/09/2008 - 20:27 | Warnen spam
Simarion schrieb am 02.09.2008 17:39 Uhr:

Ich habe eine List mit unterschiedlichen Wörtern. Diese Wörter möchte
ich nun mit einander kombinieren, wobei keins doppelt vorkommen soll.
Maximal soll das Ergebnis aus min. 2 max. 6 Wörtern bestehen.



Willst Du die Wörter zufàllig kombinieren und bei jeder Neuberechnung
eine neue Kombination bekommen?
Oder möchtest Du alle möglichen Kombinationen auflisten?

Ich habe hier mal die erste Version mit zufàlliger Kombination
angenommen. Du benötigst dafür eine Hilfsspalte.

Deine acht Worte stehen in A2:A9. In C1 wird eine eine Zufallszahl
zwischen 2 und 6 berechnet. Also die Anzahl der Wörter. In C2:C9 kommt
je eine einfache Zufallszahl. Deren Sortierung bestimmt die
Reihenfolge der acht Wörter. In B2:B9 werden die sortierten Wörter
aufgelistet; aber nur soviele wie in C1 zufàllig berechnet wurde. Der
Rest des Bereichs wird automatisch auf "" gesetzt.

A2: Haus
A3: Baum
A4: Gras
A5: Blatt
A6: Hund
A7: Katze
A8: Stamm
A9: Braun

B2: =WENN(ZEILE()-1>$C$1;"";INDEX($A$2:$A$9;RANG($C2;$C$2:$C$9)))

C1: =GANZZAHL(ZUFALLSZAHL()*5)+2
C2: =ZUFALLSZAHL()

B2 und C2 runterziehen bis Zeile 9. Spalte C ausblenden.

Peter

Ähnliche fragen