"komischer" Zugriff auf Samba

11/03/2008 - 23:37 von Christian Althoff | Report spam
Hallo/2

ich habe hier auf einem NAS (Linksys NSLU2 mit 250GB USB-Platte) auf dem
eine Linuxfirmware làuft, einen Samba-Server 3.0.28 laufen, mit
diversen freigegebenen Ordnern und diversen zugelassenen Benutzern.

Gleichzeitig haben mehrere Rechner freigegebene Laufwerke auf die von
den jeweiligen anderen Rechnern zugegriffen werden kann. Diese sollen
eigentlich durch den NAS ersetzt werden - zentrale Datenspeicherung und so.

Die beteiligten BS sind - sowohl als zur Verfügung stellende als auch
als abrufende Systeme - Linux, Win08, Win XP, Win Vista (brrrr) und
natürlich OS/2 (in Form von eCS1.13)

Alle Zugriffe der Rechner (4 Rechner mit BS-Wahl beim Rechnerstart)
untereinander funktionieren:

Win auf den Linux-PC (Samba 3.0.26)
Win auf OS/2
Win auf NSLU2
Win auf Win
Linux-PC auf WIN
Linux-PC auf OS/2
Linux auf NSLU2
OS/2 auf Linux-PC
OS/2 auf Win
OS/2 auf OS/2

Das Einzige was nicht bzw. nur eingeschrànkt funktioniert ist der
Zugriff von OS/2 auf die NSLU2.

Was funktioniert ist das Lesen der Daten, was nicht funktioniert ist das
schreiben. Wobei hier komische Effekte auftreten: es gibt eine
Fehlermeldung das die Dateien nicht kopiert wurden, aber ich bekomme die
Datei auf dem Ziel angezeigt, aber mit einer Größe von "0"

Ein anderer Versuch auf der Komandozeile "copy pr*.* x:" hat dazu
geführt das es Fehlermeldungen gab, die Dateien mit 0 Byteangelgt
wurden,aber eine Datei wurde vollstàndig kopiert.

Die schreibenden Rechner sind ein Laptop mit WLAN und ein PC mit Ethernet

Die Umlaute werden auch nicht korrekt angezeigt, korrekt schreiben kann
ich sie - wenn es denn malfunktioniert.

Hier ein Ausschnitt der smb.conf:

[global]
dos charset = 850
unix charset = iso-8859-15
display charset = iso-8859-15
workgroup = ARBEITSGRUPPE
server string = Linksys NSLU2
interfaces = ixp0, lo, #, neu
guest account = guest
username map = # neu
max log size = 10
socket options = TCP_NODELAY SO_KEEPALIVE SO_SNDBUF384 SO_RCVBUF384
load printers = No
os level = 64
preferred master = Yes
wins support = Yes
ldap ssl = no
config file = /unslung/smb.conf
create mask = 0771
force create mode = 0660
force directory mode = 0771
hosts allow = 127.0.0.1, 192.168.0.
hosts deny = 0.0.0.0/0
ea support = Yes
default case = upper
case sensitive = No
map system = Yes

[benutzer1]
comment = privat
path = /share/hdd/data/benutzer1
invalid users = @benutzer2, @benutzer3, @benutzer3
read only = No


Was im Gegensatz dazu funktioniert ist der schreibende Zugriff per FTP
(hier ist aber bisher nur der Zugriff als "root" eingerichtet)

Wenn jemand 'ne Idee hàtte!?


Mit freundlichen Grüßen

Christian Althoff
"Planung bedeutet, den Zufall durch den Irrtum zu ersetzen." (P. Ustinov)
Bei privater Mail ist die Verwendung von PGP ausdrücklich erwünscht!
PGP-Schlüssel auf http://www.dfn-pca.de/pgpkserv/
www.christian-althoff.de

 

Lesen sie die antworten

#1 Boris Kirkorowicz
12/03/2008 - 08:50 | Warnen spam
Hallo,

Am 11.03.2008 23:37 schrieb Christian Althoff:
Was funktioniert ist das Lesen der Daten, was nicht funktioniert ist das
schreiben. Wobei hier komische Effekte auftreten: es gibt eine
Fehlermeldung das die Dateien nicht kopiert wurden, aber ich bekomme die
Datei auf dem Ziel angezeigt, aber mit einer Größe von "0"



Schus ins Blaue: versuch es doch mal mit reduzierten Paketgrößen in der
IBMLAN.INI. Ich habe eingetragen:

sizworkbuf = 3900
sizmessbuf = 3900
sizreqbuf = 3900



Gruss Greetings
Boris Kirkorowicz

Falls Ihre eMail versehentlich im Spamfilter haengengeblieben zu sein
scheint, bitte das Formular unter http://www.kirk.de/mail.shtml nutzen.
If your eMail seems to be caught by the SPAM filter by mistake, please
use the form at http://www.kirk.de/mail.shtml to drop me a note.

Ähnliche fragen