Komplexe Zähl-/Vergleichsformel in Excel 2003

27/02/2009 - 13:51 von Anne | Report spam
Hallo zusammen,

ich habe ein Problem, das ich nicht lösen kann und bitte um Unterstützung:
ein Tabelle soll ausgewertet werden (ca. 3000 Sàtze) und zwar:
Name + Vorname werden geprüft und wenn mehrfach vorhanden, nur 1x gezàhlt
(Haushalte werden erfaßt).
Die Matrixformel von vor einem Jahr sieht so aus:

=SUMME((VERGLEICH(Eintragungsblatt!B1:B3000&"x"&Eintragungsblatt!C1:C3000;Eintragungsblatt!B1:B3000&"x"&Eintragungsblatt!C1:C3000;0)=ZEILE(1:3000))*1)-(SUMME((Eintragungsblatt!B1:B3000="")*(Eintragungsblatt!C1:C3000=""))>0)-1

Nun sollen an diese Haushaltszàhlung noch Werte gekoppelt werden, wie z.B.
der Regierungsbezirk, die Altersgruppe und die familiàre Situation.
Bislang wird das nur per normaler ZÄHLENWENN-Formel erfaßt. Ich benötige
Eure Unterstützung, ob so etwas überhaupt geht und wie die obige Formel
angepaßt werden kann oder ob man eine andere dafür benötigt - ich bin mit
meinem Versuch über SUMMENPRODUKT und Summe (Wenn) klàglich gescheitert

Schon jetzt vielen Dank!

Anne H.
 

Lesen sie die antworten

#1 Bernd P
01/03/2009 - 08:01 | Warnen spam
Hallo Anne,

Mein Rat: Wirf die Matrixformel weg und nutze eine Pivottabelle.
Beispiele findest Du viele im Internet, z. B.
http://www.teialehrbuch.de/Kostenlo...ieren.html
(Du wirst wohl eines der spàteren Beispiele auf dieser Website
brauchen...)

Matrixformeln sind màchtig, aber man sollte sie genau kennen, um sie
ggf. spàter anpassen zu können. Wer Zeit und Lust hat, findet in
dieser Newgroup einige Beispiele von verzweifelten Hilferufen für alte
Matrixformeln, die spàter nicht mehr passten. Deshalb sind liegen
Matrixformeln auf Platz 1 meiner "Top Flop List":
http://www.sulprobil.com/html/excel_don_ts.html

Viele Grüße,
Bernd

Ähnliche fragen